Bug 201214

Summary: www/chromium: chromium-43.0.2357.130 build fails to compile
Product: Ports & Packages Reporter: Tony Narlock <tony>
Component: Individual Port(s)Assignee: freebsd-chromium mailing list <chromium>
Status: Closed Unable to Reproduce    
Severity: Affects Only Me CC: rene
Priority: --- Flags: bugzilla: maintainer-feedback? (chromium)
Version: Latest   
Hardware: Any   
OS: Any   

Description Tony Narlock 2015-06-30 11:21:55 UTC
Related https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200617. When testing upping my kern.maxtsiz, I tried to build a DEBUG version of the chrome release and it fails.

Let me know if there's anything else I can provide. 

➜  chromium  freebsd-version -ku; uname -apKU
10.2-PRERELEASE
10.2-PRERELEASE
FreeBSD z600 10.2-PRERELEASE FreeBSD 10.2-PRERELEASE #5: Fri Jun 26 10:34:21 CDT 2015     root@z600:/usr/obj/usr/src/sys/MYKERNEL  amd64 amd64 1001519 1001519


===> The following configuration options are available for chromium-43.0.2357.130:
     CODECS=on: Compile and enable patented codecs like H.264
     DEBUG=on: Build with debugging support
     GCONF=off: GConf configuration backend support
     KERBEROS=on: Kerberos support
     PULSEAUDIO=off: PulseAudio sound server support
     TEST=off: Build and/or run tests
===> Use 'make config' to modify these settings


➜  chromium  make MAKE_JOBS_UNSAFE=yes
===>  Building for chromium-43.0.2357.130
ninja: Entering directory `out/Debug'
[1/10913] ACTION v8_snapshot: run_mksnapshot_01abb6e5ba7d6feae165fcbae91bf365
FAILED: cd ../../v8/tools/gyp; ../../../out/Debug/mksnapshot --log-snapshot-positions --logfile ../../../out/Debug/obj/v8/tools/gyp/v8_snapshot.gen/snapshot.log --random-seed 314159265 ../../../out/Debug/obj/v8/tools/gyp/v8_snapshot.gen/snapshot.cc ""
ninja: build stopped: subcommand failed.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/chromium
*** Error code 1

Stop.
make: stopped in /usr/ports/www/chromium
Comment 1 Tony Narlock 2015-06-30 14:20:13 UTC
After looking further, this doesn't seem to be limited to DEBUG. It happens on default builds as well.

===> The following configuration options are available for chromium-43.0.2357.130:
     CODECS=on: Compile and enable patented codecs like H.264
     DEBUG=off: Build with debugging support
     GCONF=off: GConf configuration backend support
     KERBEROS=on: Kerberos support
     PULSEAUDIO=off: PulseAudio sound server support
     TEST=off: Build and/or run tests
===> Use 'make config' to modify these settings



Error:

[2678/16857] CXX obj/base/process/base.memory.o
../../base/process/memory.cc:67:48: warning: backslash and newline separated by space
 #if defined(MEMORY_TOOL_REPLACES_ALLOCATOR) || \ 
 ^
[2748/16857] CXX obj/base/base.sys_info_posix.o
../../base/sys_info_posix.cc:57:5: warning: '{anonymous}::g_lazy_number_of_processors' defined but not used [-Wunused-variable]
     g_lazy_number_of_processors = LAZY_INSTANCE_INITIALIZER;
     ^
[3297/16857] CXX obj/components/storage_monitor/storage_monitor.storage_monitor_freebsd.o
../../components/storage_monitor/storage_monitor_freebsd.cc:45:29: warning: 'storage_monitor::StorageMonitor::EjectStatus storage_monitor::{anonymous}::EjectPathOnFileThread(const base::FilePath&, const base::FilePath&)' defined but not used [-Wunused-function]
 StorageMonitor::EjectStatus EjectPathOnFileThread(
                             ^
[5189/16857] ACTION v8_snapshot: run_mksnapshot_01abb6e5ba7d6feae165fcbae91bf365
FAILED: cd ../../v8/tools/gyp; ../../../out/Release/mksnapshot --log-snapshot-positions --logfile ../../../out/Release/obj/v8/tools/gyp/v8_snapshot.gen/snapshot.log --random-seed 314159265 ../../../out/Release/obj/v8/tools/gyp/v8_snapshot.gen/snapshot.cc ""
[5189/16857] CXX obj/extensions/common/api/gen/extensions/common/api/extensions_api.usb.o
ninja: build stopped: subcommand failed.
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/chromium
*** Error code 1
Comment 2 Rene Ladan freebsd_committer 2015-06-30 18:38:52 UTC
Your log does not show the actual compilation error, what happens if you run the command manually, i.e.:

cd ../../v8/tools/gyp; ../../../out/Debug/mksnapshot --log-snapshot-positions --logfile ../../../out/Debug/obj/v8/tools/gyp/v8_snapshot.gen/snapshot.log --random-seed 314159265 ../../../out/Debug/obj/v8/tools/gyp/v8_snapshot.gen/snapshot.cc ""

Also, can you update devel/py-ply to r390980 ?
Comment 3 Rene Ladan freebsd_committer 2015-07-12 12:01:53 UTC
I just updated Chromium to version 43.0.2357.132, does the problem still exist?

It builds fine in a clean Poudriere jail.
Comment 4 Tony Narlock 2015-07-17 16:43:41 UTC
Thank you Rene,

I have not been able to replicate this bug.

I have two correct builds, and unfortunately since I wasn't paying attention, I didn't nail down *specifically* what changed between this ticket and now:

- a few days ago at chromium-43.0.2357.130. The difference is in between my ticket's creation and then, I altered my /etc/make.conf.  I believe it may have been the CC/CPP= flags I had set.

- with 43.0.2357.132: I also get a clean build

I am closing this ticket. Should the same big present itself I will follow up with the information requested.