Bug 201564

Summary: sysutils/py-tmuxp: not building with python 3
Product: Ports & Packages Reporter: Tony Narlock <tony>
Component: Individual Port(s)Assignee: Ruslan Makhmatkhanov <rm>
Status: Closed FIXED    
Severity: Affects Some People CC: rm
Priority: --- Flags: tony: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
URL: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=201431
Attachments:
Description Flags
fix for python3 none

Description Tony Narlock 2015-07-14 18:33:04 UTC
Related:
- https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=201431
- http://svnweb.freebsd.org/ports?view=revision&revision=392042

"""
===>  Configuring for py34-tmuxp-0.9.0
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 25, in <module>
    readme = open('README.rst').read()
  File "/usr/local/lib/python3.4/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe4 in position 635: ordinal not in range(128)
"""
Comment 1 Ruslan Makhmatkhanov freebsd_committer 2015-07-27 13:51:29 UTC
Hello,

Tony, it doesn't configure with python3 and I marked it as such as stated in PR 201431, but the problem is indeed in tmuxp's setup.py, so it's up to you to fix it..
Comment 2 Ruslan Makhmatkhanov freebsd_committer 2015-08-23 11:49:30 UTC
Created attachment 160246 [details]
fix for python3

Hi Tony,

This patch for setup.py allows to build it both with python2 and python3. Would you release it as new version 0.9.1, or should I just add it as a patch to sysutils/py-tmuxp port?
Comment 3 Tony Narlock 2015-08-23 19:28:27 UTC
(In reply to Ruslan Makhmatkhanov from comment #2)
>  Would you release it as new version 0.9.1

Do you want to pull request it on GitHub so you get credit? It's at www.github.com/tony/tmuxp.

If not, let me know and I'll do it tmuxp and release a new version on pypi.
Comment 4 Ruslan Makhmatkhanov freebsd_committer 2015-08-23 19:47:42 UTC
Just did that: https://github.com/tony/tmuxp/pull/119
Comment 5 Tony Narlock 2015-08-23 19:52:05 UTC
(In reply to Ruslan Makhmatkhanov from comment #4)
Ok, someone just replied on it @ https://github.com/tony/tmuxp/pull/119#discussion_r37709814.

Want to switch it to ``>2``?
Comment 6 Tony Narlock 2015-08-23 20:16:46 UTC
0.9.1 is up https://pypi.python.org/pypi/tmuxp/0.9.1

I maintain tmuxp as well as the port, this looks good to me. +1
Comment 7 commit-hook freebsd_committer 2015-08-23 20:28:30 UTC
A commit references this bug:

Author: rm
Date: Sun Aug 23 20:27:30 UTC 2015
New revision: 395127
URL: https://svnweb.freebsd.org/changeset/ports/395127

Log:
  sysutils/py-tmuxp: update to 0.9.1

  New release resolves the compatibility issue with python3.
  Relax python version check in Makefile.

  PR:		201564
  Approved by:	 Tony Narlock <tony@git-pull.com> (maintainer)

Changes:
  head/sysutils/py-tmuxp/Makefile
  head/sysutils/py-tmuxp/distinfo
Comment 8 Ruslan Makhmatkhanov freebsd_committer 2015-08-23 20:29:04 UTC
Update committed. Thank you!