Bug 202744

Summary: [PATCH] graphics/qgis: Drop USES=iconv:wchar_t.
Product: Ports & Packages Reporter: Raphael Kubo da Costa <rakuco>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: Closed FIXED    
Severity: Affects Only Me CC: rhurlin
Priority: --- Keywords: patch
Version: LatestFlags: rhurlin: maintainer-feedback+
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Proposed patch none

Description Raphael Kubo da Costa freebsd_committer 2015-08-29 11:39:41 UTC
Created attachment 160482 [details]
Proposed patch

The port has a FindIconv.cmake, but it is not used anywhere, nor does the code actually call any iconv() functions. Built fine on 10.1-amd64.
Comment 1 Rainer Hurling 2015-08-30 07:27:55 UTC
Hi Raphael, Thanks for the hint.

It seems, that iconv is only needed on Windows with OSGEO4W nowadays?

I tried your patch on poudriere with 9.3, 10.2 and HEAD and all went fine. It also works quite nice without USES=iconv.

So it would be nice if you could commit the patch, thanks.
Comment 2 commit-hook freebsd_committer 2015-08-30 10:19:07 UTC
A commit references this bug:

Author: rakuco
Date: Sun Aug 30 10:18:29 UTC 2015
New revision: 395606
URL: https://svnweb.freebsd.org/changeset/ports/395606

Log:
  Drop USES=iconv:wchar_t.

  The port has a FindIconv.cmake, but it is not used anywhere, nor does the
  code actually call any iconv() functions.

  PR:		202744
  Approved by:	Rainer Hurling <rhurlin@gwdg.de> (maintainer)

Changes:
  head/graphics/qgis/Makefile