Bug 204626

Summary: 'zpool get' command help output has two small errors
Product: Base System Reporter: 214748mv
Component: binAssignee: freebsd-bugs (Nobody) <bugs>
Status: New ---    
Severity: Affects Only Me CC: pi
Priority: ---    
Version: CURRENT   
Hardware: Any   
OS: Any   

Description 214748mv 2015-11-17 09:34:12 UTC
Hi,

running the command

$ zpool get

missing property argument

usage:

       get [-Hp] [-o "all" | field[,...]] <"all" | property[,...]> <pool> ...

the following properties are supported:

       PROPERTY         EDIT   VALUES

       allocated          NO   <size>

       capacity           NO   <size>

       dedupratio         NO   <1.00x or higher if deduped>

       expandsize         NO   <size>

       fragmentation      NO   <percent>

       free               NO   <size>

       freeing            NO   <size>

       guid               NO   <guid>

       health             NO   <state>

       leaked             NO   <size>

       size               NO   <size>

       altroot           YES   <path>

       autoexpand        YES   on | off

       autoreplace       YES   on | off

       bootfs            YES   <filesystem>

       cachefile         YES   <file> | none

       comment           YES   <comment-string>

       dedupditto        YES   <threshold (min 100)>

       delegation        YES   on | off

       failmode          YES   wait | continue | panic

       listsnapshots     YES   on | off

       readonly          YES   on | off

       version           YES   <version>

       feature@...       YES   disabled | enabled | active

The feature@ properties must be appended with a feature name.

See zpool-features(7).

I notice that:

    - the property "capacity" is a <percent> and not a <size>

    - the property "name" is missing.

--
Regards,
Maurizio