Bug 204932

Summary: [new port] devel/grunt: The NodeJS JavaScript task runner
Product: Ports & Packages Reporter: Yuri Victorovich <yuri>
Component: Individual Port(s)Assignee: Yuri Victorovich <yuri>
Status: New ---    
Severity: Affects Only Me CC: rodomar705, w.schwarzenfeld
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on: 204577, 204547, 204772    
Bug Blocks: 205053    
Attachments:
Description Flags
shar archive
none
shar archive
none
shar archive (compressed bz2)
none
shar archive (compressed bz2)
none
shar archive (compressed bz2)
none
shar archive (compressed bz2)
none
shar archive none

Description Yuri Victorovich freebsd_committer 2015-12-01 09:25:40 UTC
Created attachment 163701 [details]
shar archive

Another USES=nodejs based port that is commonly used in NodeJS world
Comment 1 Yuri Victorovich freebsd_committer 2015-12-02 09:59:50 UTC
Created attachment 163741 [details]
shar archive
Comment 2 Yuri Victorovich freebsd_committer 2015-12-06 10:23:55 UTC
Created attachment 163889 [details]
shar archive (compressed bz2)
Comment 3 Yuri Victorovich freebsd_committer 2015-12-10 11:21:03 UTC
Created attachment 164042 [details]
shar archive (compressed bz2)
Comment 4 Yuri Victorovich freebsd_committer 2015-12-11 09:45:11 UTC
Created attachment 164109 [details]
shar archive (compressed bz2)
Comment 5 Yuri Victorovich freebsd_committer 2015-12-27 14:19:16 UTC
Created attachment 164725 [details]
shar archive (compressed bz2)
Comment 6 Yuri Victorovich freebsd_committer 2015-12-28 06:42:31 UTC
Created attachment 164749 [details]
shar archive
Comment 7 Rodomar705 2016-04-14 07:01:09 UTC
Sorry to bother you, however the port doesn't build anymore. Seems that one dependency from the tree has disappeared from the registry. Initially the idea was to try to update the port to the recently released 1.0, but desisted soon afterwards after seeing how are bigger the dependency tree. Tried to do the same for the single package (glob, if i'm not mistaken), but i'm literally overwhelmed by dependency and i can't get out of anywhere from there, besides getting more errors. Can you fix it?

Thanks for your work.
Comment 8 Rodomar705 2016-04-14 07:08:41 UTC
(In reply to Rodomar705 from comment #7)
Wrong, it is tap 2.3.5, sorry about that.
Comment 9 Walter Schwarzenfeld freebsd_triage 2018-01-16 07:15:19 UTC
Any news here?
Comment 10 Yuri Victorovich freebsd_committer 2018-01-16 07:17:56 UTC
This is pending USES=nodejs module. I wasn't yet able to make it reliable. I will resume work on it. It is challenging, and doesn't fit the FreeBSD ports framework well, but a lot of good software is in NodeJS.