Bug 205681

Summary: [NEW PORT] net/freeswitch: Multi-protocol soft switch
Product: Ports & Packages Reporter: corsmith
Component: Individual Port(s)Assignee: Kurt Jaeger <pi>
Status: Closed FIXED    
Severity: Affects Many People CC: corsmith, numisemis, pi
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=204967
Bug Depends on: 205680    
Bug Blocks: 204967    
Attachments:
Description Flags
svn diff of net/freeswitch
none
poudriere build log (gzip)
none
updated-1.6.6.sh
none
v3-shar none

Description corsmith 2015-12-29 02:21:28 UTC
Created attachment 164795 [details]
svn diff of net/freeswitch

Duplicate of 204967

This version is an expanded version of the port with a "build everything" philosophy.  Compared to 204967 it includes:

* all working features enabled via modules.conf - batteries included
* unified port that install sounds and music in multiple languages and bitrates as OPTIONS eliminating the need for the ancillary ports required in the past
* video functionality included
* better handling of configuration files
* installs and runs as a regular user (UIDs and GIDs already contain the user/group freeswitch)
* tested with portlint and poudriere (build logs attached)
* example configuration installed in EXAMPLESDIR so the user can choose which type of configuration they want to use.

It is a little heavy with all of the dependencies but I think it will make for a good freeswitch on FreeBSD experience.  Especially once the official packages are built and any user can simply run:

pkg install -y freeswitch
( cd /usr/local/share/examples/freeswitch/vanilla/ && pax -rw -p e . /usr/local/etc/freeswitch )
service freeswitch start
Comment 1 corsmith 2015-12-29 02:23:09 UTC
Poudriere builds logs (compressed) attached
Comment 2 corsmith 2015-12-29 02:25:08 UTC
Created attachment 164796 [details]
poudriere build log (gzip)
Comment 3 Kurt Jaeger freebsd_committer 2016-03-06 20:50:34 UTC
*** Bug 204967 has been marked as a duplicate of this bug. ***
Comment 4 Kurt Jaeger freebsd_committer 2016-03-07 09:24:29 UTC
upstream has re-arranged the MASTER_SITE. And there's 1.6.6 out.

Testbuilds@work
Comment 5 Kurt Jaeger freebsd_committer 2016-03-07 11:15:50 UTC
it includes a libtiff 4.0.2, can't it use the ports tiff, which is already at 4.0.6 ?
Comment 6 Kurt Jaeger freebsd_committer 2016-03-07 20:52:22 UTC
Created attachment 167824 [details]
updated-1.6.6.sh

Attached is an updated version, mostly builds, but fails to install at the end.
Comment 7 Kurt Jaeger freebsd_committer 2016-03-08 20:09:40 UTC
Created attachment 167869 [details]
v3-shar

This version builds to the end. Testbuilds at work.
Comment 8 Kurt Jaeger freebsd_committer 2016-03-08 21:00:31 UTC
(In reply to Kurt Jaeger from comment #5)

There are more libs in the port that might profit from using the ports version:

- devel/libtpl (1.6) vrs. 1.5 intern
- net/libsrtp (1.5.4) vrs. 1.4.5 intern
- comms/spandsp (both: 0.0.6)
- graphics/tiff (4.0.6) vrs. 4.0.2 intern
- devel/apr1 (1.5.2) vrs. 1.2.8 intern
  but: depends on apr-util (also 1.2.8)
Comment 10 Kurt Jaeger freebsd_committer 2016-03-09 17:17:37 UTC
9.3a config log:

http://people.freebsd.org/~pi/logs/freeswitch-93a-config.log
Comment 11 Šimun Mikecin 2016-03-11 09:13:47 UTC
I think we should mark that this port requires FreeBSD 10 and amd64.
This way it can be commit-ed to ports three immediately.

Later we can try to enabled it for other versions and architectures if needed.
Comment 12 commit-hook freebsd_committer 2016-03-12 15:30:45 UTC
A commit references this bug:

Author: pi
Date: Sat Mar 12 15:30:26 UTC 2016
New revision: 410895
URL: https://svnweb.freebsd.org/changeset/ports/410895

Log:
  Resurrect port: net/freeswitch

  FreeSWITCH is a scalable open source cross-platform telephony
  platform designed to route and interconnect popular communication
  protocols using audio, video, text or any other form of media. It
  was created in 2006 to fill the void left by proprietary commercial
  solutions. FreeSWITCH also provides a stable telephony platform
  on which many applications can be developed using a wide range of
  free tools.

  WWW: https://freeswitch.org

  PR:		205681
  Submitted by:	corsmith@gmail.com, numisemis@yahoo.com

Changes:
  head/net/Makefile
  head/net/freeswitch/
  head/net/freeswitch/Makefile
  head/net/freeswitch/distinfo
  head/net/freeswitch/files/freeswitch.in
  head/net/freeswitch/files/patch-build_Makefile.in
  head/net/freeswitch/files/patch-modules.conf
  head/net/freeswitch/files/patch-src_mod_applications_mod__http__cache_mod__http__cache.c
  head/net/freeswitch/files/patch-src_mod_applications_mod__redis_credis.c
  head/net/freeswitch/files/patch-src_mod_endpoints_mod__verto_ws.c
  head/net/freeswitch/files/patch-src_mod_endpoints_mod__verto_ws.h
  head/net/freeswitch/files/patch-src_mod_event__handlers_mod__rayo_xmpp__streams.c
  head/net/freeswitch/files/patch-src_mod_formats_mod__shout_mod__shout.c
  head/net/freeswitch/files/pkg-message.in
  head/net/freeswitch/pkg-descr
  head/net/freeswitch/pkg-plist
Comment 13 Kurt Jaeger freebsd_committer 2016-03-12 15:31:40 UTC
Committed with 'broken for 9', and ONLY_FOR_ARCHS=amd64.

Thanks!