Bug 206323

Summary: www/foswiki remove deprecated @dirrm, convert to options helpers
Product: Ports & Packages Reporter: Pawel Pekala <pawel>
Component: Ports FrameworkAssignee: Pawel Pekala <pawel>
Status: Closed FIXED    
Severity: Affects Only Me CC: portmaster, ports-bugs
Priority: --- Flags: portmaster: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
@dirrm & other fixes
none
@dirrm & other fixes none

Description Pawel Pekala freebsd_committer 2016-01-16 22:10:55 UTC
Created attachment 165689 [details]
@dirrm & other fixes

- Remove create-plist target using deprecated @dirrm
- Add NO_ARCH
- Don't prefix options descriptions with Installs, this makes
  them folllow global naming standards
- Convert to options helpers
- Use FOSCONFDIR for files substitutions, CONFDIR is set earlier
  and defaults to /etc, now pkg-message have correct paths
- Fix plist when APACHE=on
Comment 1 Chris Hutchinson 2016-01-17 00:57:09 UTC
(In reply to Pawel Pekala from comment #0)
> Created attachment 165689 [details]
> @dirrm & other fixes
> 
> - Remove create-plist target using deprecated @dirrm
> - Add NO_ARCH
> - Don't prefix options descriptions with Installs, this makes
>   them folllow global naming standards
> - Convert to options helpers
> - Use FOSCONFDIR for files substitutions, CONFDIR is set earlier
>   and defaults to /etc, now pkg-message have correct paths
> - Fix plist when APACHE=on

The patch looks good, Pawel. Not that I doubt it. But I don't suppose
you have any evidence it works as intended, do you?
I should probably give it a go, and post the results.

Thanks for taking the time to do this, Pawel!

--Chris
Comment 2 Pawel Pekala freebsd_committer 2016-01-17 10:46:14 UTC
Created attachment 165703 [details]
@dirrm & other fixes

Fix one minor issue, add pkg-message-noapache to SUB_FILES when APACHE=off
lost when converting to options helpers.
Comment 4 Chris Hutchinson 2016-01-17 22:11:06 UTC
Comment on attachment 165703 [details]
@dirrm & other fixes

Looks great, Pawel.

Thanks for all the time, and work you put into this!

--Chris
Comment 5 commit-hook freebsd_committer 2016-01-18 16:04:28 UTC
A commit references this bug:

Author: pawel
Date: Mon Jan 18 16:04:23 UTC 2016
New revision: 406592
URL: https://svnweb.freebsd.org/changeset/ports/406592

Log:
  - Remove create-plist target using deprecated @dirrm
  - Add NO_ARCH
  - Don't prefix options descriptions with Installs, this makes
    them folllow global naming standards
  - Convert to options helpers
  - Use FOSCONFDIR for files substitutions, CONFDIR is set earlier
    and defaults to /etc, now pkg-message have correct paths
  - Fix plist when APACHE=on

  PR:		206323
  Submitted by:	myself
  Approved by:	maintainer

Changes:
  head/www/foswiki/Makefile
  head/www/foswiki/bsd.foswiki.mk
  head/www/foswiki/files/pkg-message-apache.in
  head/www/foswiki/pkg-plist