Bug 206773

Summary: editors/libreoffice: soffice.bin process at uwait state.
Product: Ports & Packages Reporter: claudius <ccs189>
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: guru
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   

Description claudius 2016-01-31 03:35:25 UTC
Hi FreeBSD supports,
I have issue when close the window of the libreoffice.

when I close the libreoffice window, top command shows the process stuck at 'uwait' state.

I install libreoffice from pkg. I believe it doesn't come with debug symbol.

How to reproduce the issue:
1/ run libreoffice in xterm
2/ close the libreoffice screen.

Status of the process when run:
 PID USERNAME    THR PRI NICE   SIZE    RES STATE   C   TIME    WCPU COMMAND
27577 chan          5  47    0   536M   156M select  1   0:01   3.91% soffice.bin

Status of the process when close:
27577 chan          4  21    0   535M   155M uwait   0   0:01   0.01% soffice.bin

[chan@x1-carbon-bsd ~]$ ps -aux|grep libre
chan       27567   0.0  0.1  47188   7376  0  I    11:32      0:00.03 /usr/local/lib/libreoffice/program/oosplash
chan       27577   0.0  2.0 548244 159144  0  I    11:32      0:01.29 /usr/local/lib/libreoffice/program/soffice.bin --splash-pipe=5
chan       27611   0.0  0.0  14776   2644  0  S+   11:33      0:00.00 grep libre

Even when I run with --nologo option the result still the same. the libreoffice script still fired the oosplash program.

I believe the system is waiting for the splash screen to close ??


I am using FreeBSD-11-CURRENT r291249.
My hardware is x1-carbon gen1.


Thanks
Chan
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2016-01-31 05:57:41 UTC
Attempt to set portname and assign.
Comment 2 Pedro F. Giffuni freebsd_committer 2016-02-03 16:43:58 UTC
(In reply to Mark Linimon from comment #1)

The title said openoffice but the report appears to be related to libreoffice.
Both are different.

The report doesn't mention which version of Libreoffice either.
Comment 3 Matthias Apitz 2016-02-03 18:01:01 UTC
this sounds like the same issue as:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=205922

even hardware and base system (amd64 on CURRENT) is the same...
Comment 4 Tijl Coosemans freebsd_committer 2016-02-08 09:16:22 UTC

*** This bug has been marked as a duplicate of bug 205922 ***