Bug 207072

Summary: emulators/i386-wine: fix build
Product: Ports & Packages Reporter: Piotr Kubaj <pkubaj>
Component: Individual Port(s)Assignee: David Naylor <dbn>
Status: Closed FIXED    
Severity: Affects Only Me CC: fidaj
Priority: --- Flags: bugzilla: maintainer-feedback? (dbn)
Version: Latest   
Hardware: amd64   
OS: Any   

Description Piotr Kubaj freebsd_committer 2016-02-10 07:55:59 UTC
Upgrade to emulators/wine-gecko-devel broke emulators/i386-wine.
The dependency to wine-gecko-devel should be switched to wine-gecko.

Index: Makefile.inc
===================================================================
--- Makefile.inc	(revision 408618)
+++ Makefile.inc	(working copy)
@@ -41,7 +41,7 @@
 USES=		tar:xz
 BUNDLE_LIBS=	yes
 
-GECKO_RUN_DEPENDS=	${DATADIR}/gecko/wine_gecko-2.40-x86.msi:${PORTSDIR}/emulators/wine-gecko-devel
+GECKO_RUN_DEPENDS=	${DATADIR}/gecko/wine_gecko-2.40-x86.msi:${PORTSDIR}/emulators/wine-gecko
 MONO_RUN_DEPENDS=	${DATADIR}/mono/wine-mono-4.5.6.msi:${PORTSDIR}/emulators/wine-mono-devel
 
 PORTSCOUT=	limitw:1,even
Comment 1 Ivan Klymenko 2016-02-11 10:49:50 UTC
Hi.

Affect on me too.
Comment 2 commit-hook freebsd_committer 2016-02-12 16:13:34 UTC
A commit references this bug:

Author: dbn
Date: Fri Feb 12 16:13:21 UTC 2016
New revision: 408740
URL: https://svnweb.freebsd.org/changeset/ports/408740

Log:
  emulators/i386-wine: fix run depends reference to wine-gecko

  PR:		207072
  Submitted by:	Piotr Kubaj <rkubaj@anongoth.pl>

Changes:
  head/emulators/i386-wine/Makefile.inc
Comment 3 David Naylor freebsd_committer 2016-02-12 16:18:37 UTC
Thank you for your PR.
Comment 4 Piotr Kubaj freebsd_committer 2016-03-10 19:11:22 UTC
(In reply to David Naylor from comment #3)
There is similar error now in both emulators/i386-wine and emulators/i386-wine-devel. Now it's related to wine-mono update. Could you fix it?
The problem is in Makefile.inc:
-MONO_RUN_DEPENDS=
${DATADIR}/mono/wine-mono-4.5.6.msi:${PORTSDIR}/emulators/wine-mono-devel
+MONO_RUN_DEPENDS=
${DATADIR}/mono/wine-mono-4.5.6.msi:${PORTSDIR}/emulators/wine-mono
Comment 5 Piotr Kubaj freebsd_committer 2016-03-10 19:11:55 UTC
(In reply to Piotr Kubaj from comment #4)
For emulators/i386-wine-devel:
-MONO_RUN_DEPENDS=	${DATADIR}/mono/wine-mono-4.5.6.msi:${PORTSDIR}/emulators/wine-mono-devel
+MONO_RUN_DEPENDS=	${DATADIR}/mono/wine-mono-4.5.6.msi:${PORTSDIR}/emulators/wine-mono
Comment 6 commit-hook freebsd_committer 2016-03-13 12:09:34 UTC
A commit references this bug:

Author: dbn
Date: Sun Mar 13 12:09:27 UTC 2016
New revision: 410959
URL: https://svnweb.freebsd.org/changeset/ports/410959

Log:
  emulators/i386-wine-devel: update to 1.9.5

   - Update dependency on wine-mono-devel (to version 4.6.0)

  PR:		207072

Changes:
  head/emulators/i386-wine-devel/Makefile.inc
  head/emulators/i386-wine-devel/distinfo
  head/emulators/i386-wine-devel/pkg-plist
Comment 7 commit-hook freebsd_committer 2016-03-13 12:11:37 UTC
A commit references this bug:

Author: dbn
Date: Sun Mar 13 12:11:12 UTC 2016
New revision: 410960
URL: https://svnweb.freebsd.org/changeset/ports/410960

Log:
  emulators/i386-wine: update dependency on wine-mono.

  Dependency moved from wine-mono-devel to wine-mono.

  PR:		207072

Changes:
  head/emulators/i386-wine/Makefile.inc
Comment 8 David Naylor freebsd_committer 2016-03-13 12:12:12 UTC
Fixed, thanks for your PR.