Bug 209343

Summary: net/openntpd openssl-port dependency
Product: Ports & Packages Reporter: Tom Beard <tom.beard>
Component: Individual Port(s)Assignee: Christian Weisgerber <naddy>
Status: Closed FIXED    
Severity: Affects Only Me Flags: bugzilla: maintainer-feedback? (naddy)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch-Makefile.diff none

Description Tom Beard 2016-05-06 21:06:30 UTC
Created attachment 170065 [details]
patch-Makefile.diff

Port defines openssl_port=security/libressl-devel to satisfy libressl >= 2.3.2 when the TLS option is enabled

Now that security/libressl has been updated to 2.3.4 can we please update the dependency to avoid having to build other packages which require OpenSSL from ports against the -devel port
Comment 1 commit-hook freebsd_committer 2016-05-07 20:00:37 UTC
A commit references this bug:

Author: naddy
Date: Sat May  7 20:00:27 UTC 2016
New revision: 414785
URL: https://svnweb.freebsd.org/changeset/ports/414785

Log:
  For the RESSL option, switch the dependency from libressl-devel to
  security/libressl, now that the latter is new enough.

  PR:		209343
  Submitted by:	tom.beard@public-internet.co.uk

Changes:
  head/net/openntpd/Makefile
Comment 2 Christian Weisgerber freebsd_committer 2016-05-07 20:01:13 UTC
Committed, thanks.