Bug 209408

Summary: [panic] newfs cause kernel panic on powerpc64
Product: Base System Reporter: Adrian Christiansen <adrian.christiansen>
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: New ---    
Severity: Affects Only Me CC: adrian.christiansen, jhibbits, ppc
Priority: ---    
Version: CURRENT   
Hardware: powerpc   
OS: Any   

Description Adrian Christiansen 2016-05-09 22:48:14 UTC
While trying to install FreeBSD/powerpc64, snapshot r298793 of 11.0-CURRENT, the kernel would panic when the installer initialized the file system:

panic: Memory modified after free 0x713a9b0(248) val=0 @ 0x713a9b0
cpuid = 0
0xc0000000002d5de0: at .kdb_backtrace+0x5c
0xc0000000002d5f10: at .vpanic+0x190
0xc0000000002d5fd0: at .panic+0x38
0xc0000000002d6060: at .trash_ctor+0x58
0xc0000000002d60e0: at .uma_zalloc_arg+0x158
0xc0000000002d6230: at .g_vfs_strategy+0xc4
0xc0000000002d62d0: at .ffs_geom_strategy+0x228
0xc0000000002d6370: at .bufwrite+0x240
0xc0000000002d6410: at .ffs_bufwrite+0x2c8
0xc0000000002d64a0: at .bawrite+0xac
0xc0000000002d6520: at .vop_stdfsync+0x1e4
0xc0000000002d6680: at .VOP_FSYNC_APV+0x148
0xc0000000002d6710: at .sched_sync+0x3c0
0xc0000000002d6850: at .fork_exit+0xd0
0xc0000000002d68f0: at .fork_trampoline+0x10
0xc0000000002d6920: at blocked_loop+0x38
KDB: enter: panic
[ thread pid 21 tid 100061 ]
Stopped at      .kdb_enter+0x60:      ld      r2, r1, 0x28,

0 > _

I tried installing it again with the powerpc installer. While I ran the powerpc64 installer again with the drive already initialized with a file system it didn't panic. So I ran newfs from the shell and had it panic the kernel.

This is a PowerMac G5 (PowerMac9,1), running the powerpc64 installer from CD. The panic happens for both Apple Partition Tables and DOS MBR tables.

Please let me know if there's anything I've missed or things that I can test to help?
Comment 1 Adrian Christiansen 2016-05-11 12:26:20 UTC
Didn't want to give up on getting 11.0-CURRENT installed on my Powermac G5, so I partitioned the disk and installed the Bootblock from the 10.3 installer. While downloading the install-sets it crashed again, this time with this output:

fatal kernel trap:ff7e0 bufwait (bufwait) @ /usr/src/sys/kern/vfs_bio.c:3512
 2nd 0x71a4a00 dirhash (dirhash) @ /usr/src/sys/ufs/ufs/ufs_dirhash.c:281
   exception       = 0x300 (data storage interrupt)
   virtual address = 0xdeadc0dedeadc0de
   dsisr           = 0x40000000
   ssr0            = 0x61e774
   ssr1            = 0x9000000000009032
   lr              = 0x1311a4
   curthread       = 0x64564d0
          pid = 2, comm = doneq0

[ thread pid 2 tid 100014 ]
Stopped at      .biodone+0x12c: ld     r0, r9, 0x0,
db> bt
Tracing pid 2 tid 100014 td 0x64564d0
0xc00000001dc1a630: at .adadone+0x368
0xc00000001dc1a700: at .xpt_done_process+0x49c
0xc00000001dc1a7a0: at .xpt_done_td+0x104
0xc00000001dc1a850: at .fork_exit+0xd0
0xc00000001dc1a8f0: at .fork_trampoline+0x10
0xc00000001dc1a920: at blocked_loop+0x38

Don't know if this is the same issue, I'd be happy to test things to help you guys clarify any issues.
Comment 2 Justin Hibbits freebsd_committer 2017-10-28 01:13:13 UTC
Have you seen this with a more recent snapshot?  There was an issue with the loader that was found late in the 11.0 cycle, and fixed, so that may have contributed to the problem you see.  If you still see this on 11.1 and/or 12-CURRENT, please provide as much of a boot log as you're able.