Bug 211163

Summary: www/lighttpd: Update to 1.4.40
Product: Ports & Packages Reporter: Piotr Kubaj <pkubaj>
Component: Individual Port(s)Assignee: Guido Falsi <madpilot>
Status: Closed FIXED    
Severity: Affects Only Me CC: koobs, madpilot, pkubaj
Priority: --- Keywords: needs-qa, patch
Version: LatestFlags: pkubaj: maintainer-feedback+
Hardware: Any   
OS: Any   
Attachments:
Description Flags
lighttpd* patch
pkubaj: maintainer-approval+
rework mysqlauth patch, tweak Makefile
pkubaj: maintainer-approval+
diff from ../
pkubaj: maintainer-approval+
www/lighttpd 1.4.40
pkubaj: maintainer-approval+
New patch
none
Further update
pkubaj: maintainer-approval+
memcached fix pkubaj: maintainer-approval+

Description Piotr Kubaj freebsd_committer 2016-07-16 22:39:36 UTC
Created attachment 172596 [details]
lighttpd* patch

This patch contains update www/lighttpd to 1.4.40 and adapts www/lighttd-mod_h264_streaming to changed API. It also removes unnecessary patches, pets portlint and updates my email. Builds fine on 10.3-RELEASE.


The patch is relative to ${PORTSDIR}/www.
Comment 1 Bugzilla Automation freebsd_committer 2016-07-16 22:39:36 UTC
Maintainer informed via mail
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-17 08:49:49 UTC
Summary tags not needed
maintainer-feedback + only required if not reporters by maintainer
Comment 3 Piotr Kubaj freebsd_committer 2016-07-21 01:10:57 UTC
Created attachment 172763 [details]
rework mysqlauth patch, tweak Makefile

This patch reworks mysqlauth patch so that it works with Lighttpd 1.4.40 (it was broken in the previous patch). It also breaks mysqlauth patch in 5 separate patches - each one for one file. That should make it easier to maintain this patch in future.

It also modernizes Makefile.
Comment 4 Piotr Kubaj freebsd_committer 2016-07-21 01:13:57 UTC
Created attachment 172764 [details]
diff from ../

I forgot that the diff has to be made from ${PORTSDIR}/www to accomodate changes in mod_h264_streaming port :)
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-21 08:27:18 UTC
Thanks Piotr

Can you please separate out the patches for the other (not www/lighttpd) ports into new issues and add this issue ID to their "Depends on" field, if they need to be committed after this one. A cursory review appears to indicate they don't though. If they do, bumping their PORTREVISION's is probably handy so they can chase the www/lighttpd update
Comment 6 Piotr Kubaj freebsd_committer 2016-07-21 13:36:10 UTC
Created attachment 172781 [details]
www/lighttpd 1.4.40

This is the patch only for www/lighttpd port. I'll send the others shortly.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2016-07-21 13:59:05 UTC
Thanks Piotr, please confirm QA passes
Comment 8 Piotr Kubaj freebsd_committer 2016-07-21 14:37:21 UTC
(In reply to Kubilay Kocak from comment #7)
Builds fine on 10.3 with Poudriere :)
Comment 9 Guido Falsi freebsd_committer 2016-07-21 16:07:36 UTC
I noticed the NODELAY option and relative patch have been removed, has it been integrated upstream?
Comment 10 Piotr Kubaj freebsd_committer 2016-07-21 16:13:04 UTC
(In reply to Guido Falsi from comment #9)
Yes, please look at https://github.com/lighttpd/lighttpd1.4/commit/416b5729fbb0a10fb91da1e02481b1dc695b5141
Comment 11 Guido Falsi freebsd_committer 2016-07-21 16:15:12 UTC
(In reply to Piotr Kubaj from comment #10)
> (In reply to Guido Falsi from comment #9)
> Yes, please look at
> https://github.com/lighttpd/lighttpd1.4/commit/
> 416b5729fbb0a10fb91da1e02481b1dc695b5141

Thanks.

Wanted to make sure the change was intentional and motivated.

I'm testing it, it will take a little time. Please hold on.
Comment 12 Guido Falsi freebsd_committer 2016-07-21 16:35:34 UTC
While testing I noticed two issues:

- the port fails to build with all options disabled (OPENSSL too), here's a failure log for you to analyse:

http://www.madpilot.net/~mad/lighttpd.log

It looks like some "no" argument gets passed in the wrong place.

- I found this error in the logs (previous one too): 

configure: WARNING: unrecognized options: --without-memcache

Looking at configure --help I only see a --with(out)-memcached, not sure if that's the same.


could you investigate these two issues and update your patch?

Thanks.
Comment 13 Guido Falsi freebsd_committer 2016-07-21 17:16:30 UTC
Created attachment 172789 [details]
New patch

I found the cause of the failure. It's caused by how OPENSSL_CONFIGURE_WITH works.

It added --without-openssl-libs and --without-openssl-includes, which should not be added.

I slightly modified the option helpers to avoid the issue.

Please test the attached patch yourself too.

I still have no clue about the memcache issue.
Comment 14 Guido Falsi freebsd_committer 2016-07-21 17:26:41 UTC
Created attachment 172790 [details]
Further update

I made another modifications, I converted the port to USES=localbase, instead of manually modifying CPPFLAGS and LDFLAGS.

If you look at the ports/Mk/Uses/localbase.mk file you'll see it's equivalent to what the port is already doing, but a little more generalised.

Apart from this further change the diff is the same as the one I send a little while ago.
Comment 15 Piotr Kubaj freebsd_committer 2016-07-21 18:06:07 UTC
I also can't find this memcache thing in Lighttpd, but I think this is upstream bug.
Comment 16 Guido Falsi freebsd_committer 2016-07-21 18:16:04 UTC
(In reply to Piotr Kubaj from comment #15)
> I also can't find this memcache thing in Lighttpd, but I think this is
> upstream bug.

Ok but what should I do with the lines:

MEMCACHE_LIB_DEPENDS=   libmemcache.so:databases/libmemcache
MEMCACHE_CONFIGURE_WITH=memcache


These are passing an unsupported option to the configure script. Support for this should be removed or fixed.

Maybe the upstream moved to libmemcached, which we have in the ports tree?
Comment 17 Piotr Kubaj freebsd_committer 2016-07-21 18:50:58 UTC
Created attachment 172794 [details]
memcached fix

Yes, they seem to have switched to libmemcached. Fix attached.
Comment 18 Guido Falsi freebsd_committer 2016-07-21 23:37:44 UTC
Committed. Thanks!
Comment 19 commit-hook freebsd_committer 2016-07-21 23:37:47 UTC
A commit references this bug:

Author: madpilot
Date: Thu Jul 21 23:37:03 UTC 2016
New revision: 418900
URL: https://svnweb.freebsd.org/changeset/ports/418900

Log:
  - Update to 1.4.40
  - Convert to USES=localbase
  - Update MAINTAINER address
  - Remove NODELAY option, it has been integrated upstream
  - Modernize Makefile

  PR:		211163
  Submitted by:	Piotr Kubaj <pkubaj at anongoth.pl> (maintainer)

Changes:
  head/www/lighttpd/Makefile
  head/www/lighttpd/distinfo
  head/www/lighttpd/files/extra-patch-mysqlauth
  head/www/lighttpd/files/extra-patch-nodelay
  head/www/lighttpd/files/extra-patch-src_Makefile.am
  head/www/lighttpd/files/extra-patch-src_Makefile.in
  head/www/lighttpd/files/extra-patch-src_http__auth.c
  head/www/lighttpd/files/extra-patch-src_http__auth.h
  head/www/lighttpd/files/extra-patch-src_mod__auth.c
  head/www/lighttpd/files/patch-configure.ac
  head/www/lighttpd/files/patch-src-fdevent.h
  head/www/lighttpd/files/patch-src_mod__cml__lua.c
  head/www/lighttpd/files/patch-src_mod__magnet.c
  head/www/lighttpd/files/patch-src_network.c