Bug 211363

Summary: [PATCH] print/harfbuzz: Update to 1.3.0
Product: Ports & Packages Reporter: lightside <lightside>
Component: Individual Port(s)Assignee: Jan Beich <jbeich>
Status: Closed FIXED    
Severity: Affects Some People CC: gnome
Priority: --- Keywords: patch
Version: LatestFlags: bugzilla: maintainer-feedback? (gnome)
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Proposed patch (since 418357 revision)
none
Proposed patch (since 418357 revision) lightside: maintainer-approval? (gnome)

Description lightside 2016-07-25 10:45:14 UTC
Created attachment 172967 [details]
Proposed patch (since 418357 revision)

Patch to update print/harfbuzz port from 1.2.7 to 1.3.0 version.

Look following links for changes:
https://cgit.freedesktop.org/harfbuzz/tree/NEWS?id=1.3.0
https://github.com/behdad/harfbuzz/compare/1.2.7...1.3.0

- Adapt value for LIBVER
- Adapt pkg-plist

Tested with using poudriere on FreeBSD 9.3 amd64 and native build on FreeBSD 10.2 amd64
Comment 1 lightside 2016-07-25 16:24:11 UTC
Created attachment 172973 [details]
Proposed patch (since 418357 revision)

Added upstream patch (applied to configure instead of configure.ac file, because it was generated):
https://cgit.freedesktop.org/harfbuzz/commit/?id=dd31fc9f7e6d23b414b22874de96eb3c002c80ba
https://github.com/behdad/harfbuzz/pull/296

This fixes regression from 1.2.4 version:
https://cgit.freedesktop.org/harfbuzz/commit/?id=b424b6c372dfe4c0ed75a49761eb34a416819446
https://github.com/behdad/harfbuzz/commit/b424b6c372dfe4c0ed75a49761eb34a416819446
Comment 2 commit-hook freebsd_committer 2016-07-25 19:12:32 UTC
A commit references this bug:

Author: jbeich
Date: Mon Jul 25 19:11:33 UTC 2016
New revision: 419056
URL: https://svnweb.freebsd.org/changeset/ports/419056

Log:
  print/harfbuzz: update to 1.3.0

  Changes:	https://cgit.freedesktop.org/harfbuzz/tree/NEWS?id=1.3.0
  ABI:		http://abi-laboratory.pro/tracker/objects_report/harfbuzz/1.2.7/1.3.0/report.html
  PR:		211363
  Submitted by:	lightside@gmx.com
  MFH:		2016Q3

Changes:
  head/print/harfbuzz/Makefile
  head/print/harfbuzz/distinfo
  head/print/harfbuzz/files/patch-configure
  head/print/harfbuzz/pkg-plist
Comment 3 Jan Beich freebsd_committer 2016-07-25 19:12:47 UTC
Thanks. Landed.
Comment 4 commit-hook freebsd_committer 2016-07-26 18:00:57 UTC
A commit references this bug:

Author: jbeich
Date: Tue Jul 26 17:59:55 UTC 2016
New revision: 419140
URL: https://svnweb.freebsd.org/changeset/ports/419140

Log:
  MFH: r419056

  print/harfbuzz: update to 1.3.0

  Changes:	https://cgit.freedesktop.org/harfbuzz/tree/NEWS?id=1.3.0
  ABI:		http://abi-laboratory.pro/tracker/objects_report/harfbuzz/1.2.7/1.3.0/report.html
  PR:		211363
  Submitted by:	lightside@gmx.com
  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2016Q3/
  branches/2016Q3/print/harfbuzz/Makefile
  branches/2016Q3/print/harfbuzz/distinfo
  branches/2016Q3/print/harfbuzz/files/patch-configure
  branches/2016Q3/print/harfbuzz/pkg-plist