Bug 213372

Summary: Repartitioning existing disk does not work
Product: Base System Reporter: Ian Goddard <bz>
Component: miscAssignee: freebsd-bugs (Nobody) <bugs>
Status: New ---    
Severity: Affects Only Me    
Priority: ---    
Version: 11.0-STABLE   
Hardware: amd64   
OS: Any   

Description Ian Goddard 2016-10-11 10:12:10 UTC
Existing 1 Tb Toshiba 3.5" SATA partitioned with 11RC3
932G GPT
512KB freebsd-boot
920GB freebsd-ufs as /
12GB freebsd-swap

11RELEASE DVD (the final version) in USB drive.  Motherboard (ASRock Q1900TM-ITX) offers USB and UEFI options to boot drive.  Select USB.  Select UK ISO-8859-1 option which tests OK except for the usual missing £ sign.

Select Manual partioning.
Delete swap and / partitions.
Select Create

Add partition dialog appears immediately overlain by Error dialog saying there is no / partition etc.
Accept Yes to continue.

Both dialogs are cleared and the entire free space is occupied by a 932GB UFS partition.  Attempting to modify this does not permit modification to size.

Alternatively select the EUFI option for the DVD drive and proceed as before with the partition table reverted.

Enter 600GB as the size for the root partition.

There was an error dialog complaining about lack of a bootable partition.  Accept the offer to add this and it ignores the existing freebsd-boot partition and adds an EFI partition followed by the new UFS partiton

The new partition table shows the UFS partition as 0.3TB.

Select Modify.  The Modify dialog showns the partition as -300GB (not exactly -300 but I didn't note the two least significant digits).

Deleted this and tried creating a 0.6TB partition.  T is not accepted.

Deleted again and tried adding a 300GB partition which is displayed as 0.7TB

If I attempt to add a third partition the sizing looks sane enough but with the insane size being shown I'm not prepared to commit this.

I still have the original partitions set up if you want me to experiment.
Comment 1 Ian Goddard 2016-10-11 11:29:42 UTC
(In reply to Ian Goddard from comment #0)
I've now tried the CD Disk1 download.  Using the USB option from the m/board menu it behaves in the same way as I described for the UEFI option for the DVD except that it installs a second freebsd-boot partition instead of an EFI one.