Bug 213501

Summary: Screen blank after sleep/resume
Product: Base System Reporter: Tobias <tobias>
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: New ---    
Severity: Affects Some People CC: eadler, grahamperrin, jhb, johalun0, miner.ben07
Priority: --- Keywords: regression
Version: 11.0-STABLE   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
dmesg
none
syslog sleep/resume none

Description Tobias 2016-10-15 15:20:11 UTC
After sleep/resume LCD screen is blank. Have tried to sleep/resume from X, and without X, same behavior. 

Was running FreeBSD 10.3 before upgrading to 11, and in 10.3 resume worked.

Is there a work around to "reset" the screen some way?

Attaching dmesg and syslog when sleeping/resuming.
Comment 1 Tobias 2016-10-15 15:21:11 UTC
Created attachment 175780 [details]
dmesg
Comment 2 Tobias 2016-10-15 15:21:51 UTC
Created attachment 175781 [details]
syslog sleep/resume
Comment 3 Johannes Lundberg 2018-05-17 09:58:38 UTC
I'm gonna revive this one. On my Broadwell laptop it works as expected IF I have i915kms (drm-stable-kmod package) loaded.

However, when suspending from console (with no drm driver loaded), the screen does not come back on after resume. The system is fully operational though. 

In resumed state with black screen (from ssh):

startx with scfb driver won't make the screen come on.

kldload i915kms will make the screen come on.


UEFI amd64 boot with kernel version r333603
Comment 4 Andriy Gapon freebsd_committer 2018-05-17 17:02:49 UTC
I can confirm the same behaviour on an AMD based system with radeon graphics.
Comment 5 John Baldwin freebsd_committer freebsd_triage 2018-06-15 22:17:56 UTC
There's no practical way to fix resume without a GPU driver.  There's simply no GPU-independent method of turning the display back on.  A GPU driver is required to enable the screen on modern systems (on older systems the BIOS sometimes turned the screen back on for you, but that hasn't been true for several years now).

However, the original bug report does have the GPU driver it seems (since it is suspending in X) so is different from the report in comment #4 (which we can never fix).
Comment 6 Andriy Gapon freebsd_committer 2018-06-17 21:13:55 UTC
(In reply to John Baldwin from comment #5)
John, I see that the original report mentions X but I do not see any mention of a GPU driver (attachments have nothing too).  I guess that X with vesa driver would behave the same as any other case where a GPU driver is not loaded?
Comment 7 John Baldwin freebsd_committer freebsd_triage 2018-06-18 14:34:09 UTC
(In reply to Andriy Gapon from comment #6)
Yes, X with VESA will most likely not work aside from an older BIOS.
Comment 8 miner.ben07 2021-06-24 20:40:38 UTC
kldload radeonkms fixed it for me. It seems to have something to do with the DRM driver, I'm not sure why though.