Bug 216643

Summary: emulators/open-vm-tools: fails to build with clang 4.0
Product: Ports & Packages Reporter: Jan Beich <jbeich>
Component: Individual Port(s)Assignee: Steve Wills <swills>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: dim
Priority: --- Keywords: needs-patch
Version: LatestFlags: bugzilla: maintainer-feedback? (swills)
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=216644
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=216645
Bug Depends on:    
Bug Blocks: 216008    

Description Jan Beich freebsd_committer 2017-01-31 00:14:43 UTC
hgfsServer.c:5709:50: error: taking address of packed member 'actualSize' of class or structure 'HgfsReplyReadV3' may result in an unaligned pointer value [-Werror,-Waddress-of-packed-member]
                                                &reply->actualSize);
                                                 ^~~~~~~~~~~~~~~~~
hgfsServer.c:5729:63: error: taking address of packed member 'actualSize' of class or structure 'HgfsReplyRead' may result in an unaligned pointer value [-Werror,-Waddress-of-packed-member]
                                             reply->payload, &reply->actualSize);
                                                              ^~~~~~~~~~~~~~~~~

http://package18.nyi.freebsd.org/data/headamd64PR216008-default/2017-01-29_16h09m05s/logs/errors/open-vm-tools-1280544_16,1.log
http://package18.nyi.freebsd.org/data/headamd64PR216008-default/2017-01-29_16h09m05s/logs/errors/open-vm-tools-nox11-1280544_16,1.log
Comment 1 Jan Beich freebsd_committer 2017-01-31 00:15:30 UTC
open-vm-tools-10.1.0,2 is also affected: http://slexy.org/view/s2UUHbchnF
Comment 2 Dimitry Andric freebsd_committer 2017-02-04 21:15:59 UTC
I proposed a fix in bug 216263.

*** This bug has been marked as a duplicate of bug 216263 ***