Bug 217042

Summary: editors/libreoffice: configure: error: libGL required
Product: Ports & Packages Reporter: O. Hartmann <ohartmann>
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Closed Overcome By Events    
Severity: Affects Many People Flags: bugzilla: maintainer-feedback? (office)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description O. Hartmann 2017-02-12 17:10:47 UTC
editors/libreoffice fails to build (among port multimedia/ffmpeg) after  Xorg server has been updated to 1.18.4.

Build system is FreeBSD 12.0-CURRENT #131 r313648: Sat Feb 11 20:14:28 CET 2017 amd64, ports tree revision is at 433953.

Graphical/GPU backend is nvidia (x11/nvidia-driver).

editors/libreoffice fails with:

[...]
checking whether to enable the VLC avmedia backend... no
checking for glBegin in -lGL... no
configure: error: libGL required.
===>  Script "configure" failed unexpectedly.
Please report the problem to office@FreeBSD.org [maintainer] and attach the
"/usr/ports/editors/libreoffice/work/libreoffice-5.2.5.1/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/editors/libreoffice
*** Error code 1