Bug 218859

Summary: net/dhcp6: sometimes fails to build with poudriere due to parallel make issues
Product: Ports & Packages Reporter: Craig Leres <leres>
Component: Individual Port(s)Assignee: Hiroki Sato <hrs>
Status: Closed FIXED    
Severity: Affects Only Me Flags: bugzilla: maintainer-feedback? (hrs)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch
none
Poudriere build log showing failure to build none

Description Craig Leres freebsd_committer 2017-04-24 21:21:59 UTC
I have 24-core poudriere build server that does daily builds and is great for detecting parallel build problems. Occasionally it fails to build net/dhcp6 and when it does the build log shows three attempts to rename y.tab.c to cfparse.c but only the two succeed (see attached).

I believe the problem is that the Makefile has an explicit (but unnecessary dependency) for y.tab.h. When a parallel make happens to build y.tab.h and cftoken.c at the same time one of these fails.

Clearly y.tab.h will be created as a side effect of running flex on cftoken.l to create cftoken.c and only cftoken.c includes y.tab.h so my patch removes the unnecessary dependency. 

I also submitted the attached patch to upstream back in February:

    https://sourceforge.net/p/wide-dhcpv6/bugs/38/
Comment 1 Craig Leres freebsd_committer 2017-04-24 21:22:28 UTC
Created attachment 182059 [details]
patch
Comment 2 Craig Leres freebsd_committer 2017-04-24 21:23:41 UTC
Created attachment 182060 [details]
Poudriere build log showing failure to build
Comment 3 commit-hook freebsd_committer 2018-08-16 01:07:36 UTC
A commit references this bug:

Author: leres
Date: Thu Aug 16 01:06:56 UTC 2018
New revision: 477304
URL: https://svnweb.freebsd.org/changeset/ports/477304

Log:
  Fix Makefile dependency so that cfparse.c and y.tab.h exist
  before cftoken.c is generated or compiled.

  PR:		218859
  Reviewed by:	ler (mentor)
  Approved by:	maintainer timeout (68 weeks), ler (mentor)
  Differential Revision:	https://reviews.freebsd.org/D16738

Changes:
  head/net/dhcp6/files/patch-Makefile.in