Bug 220048

Summary: SoftIron OverDrive 1000 reports "no time-of-day clock registered"
Product: Base System Reporter: Ed Maste <emaste>
Component: armAssignee: freebsd-arm (Nobody) <freebsd-arm>
Status: Closed DUPLICATE    
Severity: Affects Only Me    
Priority: ---    
Version: CURRENT   
Hardware: Any   
OS: Any   

Description Ed Maste freebsd_committer 2017-06-16 14:30:04 UTC
From dmesg,

WARNING: WITNESS option enabled, expect reduced performance.
Trying to mount root from ufs:/dev/ada0p2 [rw]...
uhub0: 4 ports with 4 removable, self powered
warning: no time-of-day clock registered, system time will not be set accurately
msk0: link state changed to DOWN

However, I tried the following steps:
1) ran ntpdate to set the correct time
2) powered down
3) unplugged the network cable
4) booted
and noticed that the real time is still correct.
Comment 1 Ed Maste freebsd_committer 2017-06-16 14:31:37 UTC
See r301306
Comment 2 Ed Maste freebsd_committer 2017-06-16 14:39:38 UTC
Andy points out the time is taken from the fs shutdown in the absence of a RTC which is what I'm observing here.
Comment 3 Ed Maste freebsd_committer 2017-06-16 14:40:20 UTC

*** This bug has been marked as a duplicate of bug 212185 ***