Bug 221348

Summary: graphics/libdmtx is fine with ImageMagick-7
Product: Ports & Packages Reporter: Mikhail T. <mi>
Component: Individual Port(s)Assignee: Hiroki Sato <hrs>
Status: Closed Overcome By Events    
Severity: Affects Only Me CC: ale, freebsdbugs, ports
Priority: --- Flags: bugzilla: maintainer-feedback? (hrs)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Be satisfied with any version of libMagickWand
none
libdmtx port shar none

Description Mikhail T. 2017-08-08 21:52:13 UTC
Created attachment 185170 [details]
Be satisfied with any version of libMagickWand

Currently, the port can not be built if ImageMagick-7 is installed instead of 6. There is no reason for it being so particular...

Also, I can not find, where IM is even used in dmtx -- certainly the libdmtx.so.0.0.0 is not linked with anything installed by IM. Perhaps, the entire dependency is not needed at all?
Comment 1 Chris 2019-01-02 15:51:55 UTC
I can confirm that removing the dependency on ImageMagick 6 does not cause any compilation issues. Reading the CMakeLists.txt shows no requirement for ImageMagick at all.

Removing this dependency will help greatly as this package is pulled in by the KDE Plasma Desktop preventing installation of any packages requiring ImageMagick 7 due to install conflicts between ImageMagick 6 and 7.
Comment 2 Henrik Hudson 2019-02-15 17:18:13 UTC
I can confirm. This was blocking parts of KDE for myself as well.

I also couldn't find any reference to ImageMagick in the configure, Makefile or source code. I've removed the LIB dependency completely.

I also updated the source to GitHub and the latest version, re-did the patch and updated some of the build settings.

GitHub: https://github.com/dmtx/libdmtx
GitHub thread referencing change of owner / source repo:
https://github.com/dmtx/libdmtx/issues/18

shar attached.
Comment 3 Henrik Hudson 2019-02-15 17:18:48 UTC
Created attachment 202044 [details]
libdmtx port shar
Comment 4 Alex Dupre freebsd_committer 2019-11-23 08:28:15 UTC
I've completely removed the useless ImageMagick dependency.