Bug 221644

Summary: graphics/qgis: Update to 2.18.12
Product: Ports & Packages Reporter: Rainer Hurling <rhurlin>
Component: Individual Port(s)Assignee: Thomas Zander <riggs>
Status: Closed FIXED    
Severity: Affects Only Me CC: rhurlin, riggs
Priority: --- Keywords: patch
Version: LatestFlags: rhurlin: maintainer-feedback+
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch updates graphics/qgis from 2.18.7 to 2.18.12 rhurlin: maintainer-approval+

Description Rainer Hurling 2017-08-20 06:49:24 UTC
Created attachment 185599 [details]
patch updates graphics/qgis from 2.18.7 to 2.18.12

This minor update from QGIS 2.18.7 to 2.18.12 comes with some new features and many bugfixes.


Changes of the port:
- Update to 2.18.12
- Add new dependency textproc/xerces-c3
- Swap position of USES and USE_GITHUB
- USES=sqlite:3 instead sqlite
- Use GRASS7 now, that it is in the ports
- No direct deps to PostgreSQL and PostGIS
- Update pkg-plist

As a response to bug #218341 this PR detaches from direct dependencies to PostgreSQL and PostGIS (experimentally). This is only tested on HEAD and seems to work, but can be reversed if needed.


The patch was tested on Poudriere (10.3i/a, 11.0i/a  and, HEADi/a, with options all enabled, all disabled and default).

portlint -AC seems happy.
Comment 1 commit-hook freebsd_committer 2017-08-20 12:44:44 UTC
A commit references this bug:

Author: riggs
Date: Sun Aug 20 12:44:21 UTC 2017
New revision: 448420
URL: https://svnweb.freebsd.org/changeset/ports/448420

Log:
  Update to upstream version 2.18.12

  Detailed maintainer log:
  - Update to 2.18.12
  - Add new dependency textproc/xerces-c3
  - Swap position of USES and USE_GITHUB
  - USES=sqlite:3 instead sqlite
  - Use GRASS7 now, that it is in the ports
  - No direct deps to PostgreSQL and PostGIS
  - Update pkg-plist

  PR:		221644
  Submitted by:	rhurlin@gwdg.de (maintainer)

Changes:
  head/graphics/qgis/Makefile
  head/graphics/qgis/distinfo
  head/graphics/qgis/pkg-plist