Bug 221885

Summary: [NEW PORT] games/vcmi: Open-source engine for Heroes of Might and Magic III
Product: Ports & Packages Reporter: Piotr Kubaj <pkubaj>
Component: Individual Port(s)Assignee: Piotr Kubaj <pkubaj>
Status: Closed Not A Bug    
Severity: Affects Only Me CC: amdmi3, greg, w.schwarzenfeld
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on: 222052    
Bug Blocks:    
Attachments:
Description Flags
shar
none
vcmi_fix.patch
none
shar
none
vcmi.patch none

Description Piotr Kubaj freebsd_committer 2017-08-28 23:02:07 UTC
This shar contains the port for vcmi - open-source engine for Heroes of Might and Magic III.

Build-tested on Poudriere with 10.3-RELEASE and build- and run-tested on 11-STABLE.

Portlint says:
WARN: /usr/local/poudriere/ports/default/games/vcmi/pkg-message: possible use of absolute pathname "/path/to/iso/or/cd".                                                                                         
WARN: /usr/local/poudriere/ports/default/games/vcmi/pkg-message: possible use of absolute pathname "/path/to/gog.com/ins...".                                                                                    
WARN: /usr/local/poudriere/ports/default/games/vcmi/pkg-message: possible use of absolute pathname "/path/to/h3/data".

That is fine.
Comment 1 Piotr Kubaj freebsd_committer 2017-08-28 23:03:24 UTC
Created attachment 185850 [details]
shar
Comment 2 Piotr Kubaj freebsd_committer 2017-08-30 18:45:56 UTC
Since you assigned yourself, I guess I need to clarify a bit.

Since sending the patch, I have acquired a copy of HoMM3 and could test the actual game.

Main menu works as expected, but I have a problem when I launch the main game. There is failed assertion for boost:
Assertion failed: (this->is_initialized()), function get, file /usr/local/include/boost/optional/optional.hpp, line 1107.

I'm at a dead end here.
Comment 3 Piotr Kubaj freebsd_committer 2017-09-04 15:23:25 UTC
(In reply to Piotr Kubaj from comment #2)
I think I got it. Git snapshot is needed though. FuzzyLite library (not in ports) is also needed, so I'm going to send a PR for it first.
Comment 4 Greg V 2017-09-28 22:05:14 UTC
Created attachment 186789 [details]
vcmi_fix.patch

Hi, here's a patch for the port, fully playable for me on 12-CURRENT!
Comment 5 Greg V 2017-09-28 22:55:43 UTC
* by "fully playable" I actually mean "not playable" :D

It sometimes crashes when doing actions like building stuff in cities (core dump mentions libSDL2_mixer-2.0.so.0`Mix_LoadWAV_RW + 823 — sound related…) and sometimes the server stops working with this message:

System message: Server encountered a problem: Player 0 has to answer queries  before attempting any further actions. Top query is A query of type 20CBlockingDialogQuery and qid=5 affecting players (0)!
Lost connection to server, ending listening thread!
Comment 6 Piotr Kubaj freebsd_committer 2017-10-02 13:08:16 UTC
Created attachment 186862 [details]
shar

Could you try this shar? Seems like CMAKE_BUILD_TYPE=RelWithDebInfo needs to be set.
Comment 7 Greg V 2017-10-02 13:15:09 UTC
(In reply to Piotr Kubaj from comment #6)
I added RelWithDebInfo in my patch, yeah, release builds crash when clicking new game.

Do you get the "Player X has to answer queries" error when playing though? (Specifically when accepting dialog boxes)
Comment 8 Greg V 2018-03-21 22:58:54 UTC
Created attachment 191726 [details]
vcmi.patch

Here's a more recent version. Still getting the "Player 0 has to answer queries  before attempting any further actions" server crashes :(
Comment 9 Piotr Kubaj freebsd_committer 2018-03-22 19:22:05 UTC
(In reply to Greg V from comment #8)
I'm not sure whether something changed with VCMI, but right now I am able to play without any problems. The reason may be that I switched to CURRENT, but I have no way to verify with 11-STABLE.

@amdmi3
Based on this, could this port be committed? It looks like it works nice on CURRENT.
Comment 10 Greg V 2018-03-22 19:46:06 UTC
(In reply to Piotr Kubaj from comment #9)
I was always on CURRENT! Maybe the problem is with my game assets install / configuration or something…
Comment 11 Piotr Kubaj freebsd_committer 2018-03-22 23:01:02 UTC
(In reply to Greg V from comment #10)
How old is your CURRENT snapshot? I upgraded yesterday, maybe something was fixed...
Comment 12 Greg V 2018-03-23 00:21:36 UTC
(In reply to Piotr Kubaj from comment #11)
A week and a half old. I really doubt that the system had a bug that impacted vcmi. I'll try different game data.
Comment 13 Piotr Kubaj freebsd_committer 2018-03-28 17:59:32 UTC
(In reply to Greg V from comment #12)
Looks like I was happy too early :/
It's now possible to launch a map, but after a few turns I encounter the problem you mentioned.
Comment 14 Walter Schwarzenfeld freebsd_triage 2019-08-08 05:45:15 UTC
Any news here?
Comment 15 Piotr Kubaj freebsd_committer 2019-08-08 10:58:08 UTC
(In reply to Walter Schwarzenfeld from comment #14)
I will test whether it works OK now (there were serious stability issues before) and will post a DR if it does later.
Comment 16 Piotr Kubaj freebsd_committer 2019-09-27 22:59:40 UTC
Looks like it doesn't even build currently and the errors are non-trivial.