Bug 222342

Summary: ports-mgmt/porttools: creates invalid configuration for bitcoin port
Product: Ports & Packages Reporter: Christopher Hall <hsw>
Component: Individual Port(s)Assignee: Steven Kreuzer <skreuzer>
Status: New ---    
Severity: Affects Only Me CC: hsw
Priority: --- Flags: bugzilla: maintainer-feedback? (skreuzer)
Version: Latest   
Hardware: Any   
OS: Any   

Description Christopher Hall 2017-09-15 01:05:46 UTC
The port test in an updated litecoin port fails with an unhelpful error 1, while a normal make is successful. 
I tracked this down to moc not being found during port test. 
However looking at the relevant config log lines I see that they are different during port test and normal make.

I also see the same problem with the net-p2p/bitcoin port.

It is interesting to note that moc,uic and rcc are affected, but lrelease and lupdate always have correct path.

For port test: (invalid /tmp paths)

checking for QT... yes
checking for QT_TEST... no
checking for QT_DBUS... yes
checking for static Qt... no
checking whether -fPIE can be used with this Qt config... no
checking for moc-qt5... /tmp/litecoin-0.14.2/lib/qt5/bin/moc
checking for uic-qt5... /tmp/litecoin-0.14.2/lib/qt5/bin/uic
checking for rcc-qt5... /tmp/litecoin-0.14.2/lib/qt5/bin/rcc
checking for lrelease-qt5... no
checking for lrelease5... no
checking for lrelease... /usr/local/lib/qt5/bin/lrelease
checking for lupdate-qt5... no
checking for lupdate5... no
checking for lupdate... /usr/local/lib/qt5/bin/lupdate
checking whether to build Litecoin Core GUI... yes (Qt5)

With a normal "make configure": (all paths ok)

checking for QT... yes
checking for QT_TEST... no
checking for QT_DBUS... yes
checking for static Qt... no
checking whether -fPIE can be used with this Qt config... no
checking for moc-qt5... /usr/local/lib/qt5/bin/moc
checking for uic-qt5... /usr/local/lib/qt5/bin/uic
checking for rcc-qt5... /usr/local/lib/qt5/bin/rcc
checking for lrelease-qt5... no
checking for lrelease5... no
checking for lrelease... /usr/local/lib/qt5/bin/lrelease
checking for lupdate-qt5... no
checking for lupdate5... no
checking for lupdate... /usr/local/lib/qt5/bin/lupdate
checking whether to build Litecoin Core GUI... yes (Qt5)
Comment 1 Christopher Hall 2017-09-15 01:23:29 UTC
For reference bug 222343 contains my  updates to the litecoin, litecoin-utils and litecoin-daemon.