Bug 223109

Summary: x11-servers/xorg-server: Fix broken vmmouse detection
Product: Ports & Packages Reporter: Thomas Hellström <thellstrom>
Component: Individual Port(s)Assignee: freebsd-x11 (Nobody) <x11>
Status: Open ---    
Severity: Affects Many People CC: crees, jsavanyo, jwolfe, mp, thellstrom, vmware-gos-qa
Priority: --- Flags: bugzilla: maintainer-feedback? (x11)
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
Replacement patch-config_devd.c with automatic vmmouse detection none

Description Thomas Hellström 2017-10-19 11:41:50 UTC
Created attachment 187303 [details]
Replacement patch-config_devd.c with automatic vmmouse detection

Vmmouse detection has never worked with devd and hence, vmmouse has been more or less useless since at least FreeBSD 10.3.

I've implemented a fix in the devd config backend. It's not super clean, but given the version of the devd config backend that's upstream, I guess this will do for now.

Please review for security since we're calling an external application (vmmouse_detect) as root. The utility vmmouse_detect is part of the xf86-input-vmmouse package / port.

Also if possible, please include in all maintained freebsd versions.
Comment 1 Chris Rees freebsd_committer 2020-01-17 19:45:18 UTC
Sorry this one hasn't been seen.

- Does vmmouse still not work without this?

- I don't see any issues, especially as it's all based on const char *

- Please would you do it as a diff either to the current patch or diff config_devd.c before and after your changes?

- Rather than hard-coding /usr/local, you should use %%LOCALBASE%%, and then in

post-patch:
    ${REINPLACE_CMD} 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/path-to-config_devd.c

(but that's not really your problem, a committer would do that for you)