Bug 223324

Summary: editors/abiword: Unusable with GTK 3.22+
Product: Ports & Packages Reporter: ILUXA <iluxa>
Component: Individual Port(s)Assignee: freebsd-gnome mailing list <gnome>
Status: New ---    
Severity: Affects Many People CC: uzsolt, w.schwarzenfeld
Priority: --- Keywords: easy, needs-qa, patch
Version: LatestFlags: bugzilla: maintainer-feedback? (gnome)
Hardware: Any   
OS: Any   

Description ILUXA 2017-10-30 15:35:13 UTC
When using abiword with gtk3-3.22 (or newer), text in abiword is unreadable,
as described here - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=842443

Please add this patch, to fix the issue - https://bugzilla.abisource.com/attachment.cgi?id=5837&action=view

I can report that, after rebuilding abiword with this patch, the issue gone away.
Comment 1 Jan Beich freebsd_committer 2017-11-01 04:17:39 UTC
(In reply to ILUXA from comment #0)
> https://bugzilla.abisource.com/attachment.cgi?id=5837&action=view

Linking to an upstream commit instead may save maintainer a bit of time.

https://www.abisource.com/viewvc?view=rev&revision=35394

and can be converted to

PATCH_SITES=	https://github.com/AbiWord/${PORTNAME}/commit/
PATCHFILES=	cec2fda355b6.patch:-p1
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-02-14 20:09:51 UTC
I have tried an update to 3.0.2 see Bug #Bug 220975. Builds and starts fine. But it needed more runtests.
Comment 3 Zsolt Udvari 2019-07-23 07:25:55 UTC
What about this bug?
Comment 4 Walter Schwarzenfeld freebsd_triage 2019-07-23 11:12:25 UTC
In Bug #Bug 220975 is a working patch. Don't know why nobody commit this.