Bug 224088

Summary: comms/usrp: fails to build with boost 1.66
Product: Ports & Packages Reporter: Jan Beich <jbeich>
Component: Individual Port(s)Assignee: hamradio (Nobody) <hamradio>
Status: Closed Overcome By Events    
Severity: Affects Only Me CC: rene, w.schwarzenfeld
Priority: --- Keywords: needs-patch
Version: LatestFlags: bugzilla: maintainer-feedback? (hamradio)
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=224087
Bug Depends on:    
Bug Blocks: 223922    
Attachments:
Description Flags
svn-diff-usrp-boost_1_66
none
svn-diff-usrp-boost_1_66_v2
none
svn-diff-usrp-boost_1_66_v2
none
svn-diff-usrp-boost_1_66_v3 none

Description Jan Beich freebsd_committer 2017-12-04 17:44:32 UTC
As part of exp-run in bug 223922 this port was found to break on Boost update. If the issue won't disappear on its own by Boost release I plan to mark the port as BROKEN. Can you check with upstream maintainer or help with a fix?

$ fetch -qo- 'https://reviews.freebsd.org/D13279?download=true' | patch -Efsp0 -d /usr/ports
$ make all deinstall install clean -C/usr/ports/devel/boost-libs
$ make -C/usr/ports/comms/usrp
[...]
host/lib/transport/udp_zero_copy.cpp:193:29: error: no member named 'native' in 'boost::asio::basic_datagram_socket<boost::asio::ip::udp>'
        _sock_fd = _socket->native();
                   ~~~~~~~  ^

http://package23.nyi.freebsd.org/data/103i386-default-PR223922/2017-12-02_11h06m37s/logs/errors/usrp-3.4.3_15.log
http://package22.nyi.freebsd.org/data/103amd64-default-PR223922/2017-12-02_11h06m39s/logs/errors/usrp-3.4.3_15.log
http://package22.nyi.freebsd.org/data/111amd64-default-PR223922/2017-12-03_09h31m05s/logs/errors/usrp-3.4.3_15.log
http://package23.nyi.freebsd.org/data/111i386-default-PR223922/2017-12-03_09h31m14s/logs/errors/usrp-3.4.3_15.log
Comment 1 Jan Beich freebsd_committer 2017-12-04 17:46:58 UTC
I forgot to adjust error message from comm/uhd. However, comms/usrp is only slightly different:

host/lib/transport/udp_zero_copy.cpp:166:29: error: no member named 'native' in 'boost::asio::basic_datagram_socket<boost::asio::ip::udp>'
        _sock_fd = _socket->native();
                   ~~~~~~~  ^
Comment 2 Jan Beich freebsd_committer 2018-02-14 05:45:02 UTC
This port was marked BROKEN in ports r459315. Do you plan to apply a fix similar to ports r459615?
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-02-14 11:26:44 UTC
Created attachment 190608 [details]
svn-diff-usrp-boost_1_66

Based on this patch 
http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/2017-December/027274.html

Added and changed some things. Added LIB_DEPENDS to Makefile.
Should work (in the moment only test with the port).
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-02-14 11:31:19 UTC
Created attachment 190609 [details]
svn-diff-usrp-boost_1_66_v2

First was wrong svn-diff.
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-02-14 13:02:28 UTC
Created attachment 190613 [details]
svn-diff-usrp-boost_1_66_v2

Forgot remove broken.
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-02-14 13:10:30 UTC
Created attachment 190614 [details]
svn-diff-usrp-boost_1_66_v3

svn ...
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-02-14 16:52:25 UTC
Poudriere tests with 10.4amd64 and 11.1amd64 ok.
Comment 8 Jan Beich freebsd_committer 2018-07-17 09:20:37 UTC
portmgr@ set EXPIRATION_DATE in ports r474787. Do you plan to fix or update the port?
Comment 9 Rene Ladan freebsd_committer 2018-08-21 18:32:07 UTC
Maintainer timeout and patch is no longer valid, removing port.