Bug 224108

Summary: ftp/py-pycurl: py27-pycurl and py36-pycurl conflict with each other
Product: Ports & Packages Reporter: Ting-Wei Lan <lantw44>
Component: Individual Port(s)Assignee: Po-Chuan Hsieh <sunpoet>
Status: Closed FIXED    
Severity: Affects Only Me Flags: bugzilla: maintainer-feedback? (sunpoet)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description Ting-Wei Lan 2017-12-05 11:31:54 UTC
# pkg install py27-pycurl py36-pycurl

New packages to be INSTALLED:
	py27-pycurl: 7.43.0
	py36-pycurl: 7.43.0

Checking integrity... done (1 conflicting)
  - py36-pycurl-7.43.0 conflicts with py27-pycurl-7.43.0 on /usr/local/share/doc/pycurl/AUTHORS

Is it possible to install pycurl for multiple versions of python on the same system?
Comment 1 commit-hook freebsd_committer 2017-12-07 16:01:28 UTC
A commit references this bug:

Author: sunpoet
Date: Thu Dec  7 16:00:23 UTC 2017
New revision: 455712
URL: https://svnweb.freebsd.org/changeset/ports/455712

Log:
  Add DOCS option

  - Fix documentation installation:
    - Avoid conflicts between FLAVORS
    - Do not install license files
  - Bump PORTREVISION for package change

  PR:		224108
  Reported by:	Ting-Wei Lan <lantw44@gmail.com>

Changes:
  head/ftp/py-pycurl/Makefile
  head/ftp/py-pycurl/files/
  head/ftp/py-pycurl/files/patch-setup.py
Comment 2 Po-Chuan Hsieh freebsd_committer 2017-12-07 16:04:31 UTC
Fixed. Thanks!