Bug 225489

Summary: [NEW PORT] sysutils/lizardfs: distributed, parallel, geo-redundant filesystem
Product: Ports & Packages Reporter: Michal Bielicki <cypromis>
Component: Individual Port(s)Assignee: John Hixson <jhixson>
Status: Closed FIXED    
Severity: Affects Many People CC: cypromis, florian.heigl, koobs, marin, me, swills
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
shell archive of lizardfs 3.12.0 port
none
UIDs patch to add user lizardfs
none
GIDs patch to add group lizardfs none

Description Michal Bielicki 2018-01-27 12:24:07 UTC
Created attachment 190106 [details]
shell archive of lizardfs 3.12.0 port

Version 3.12.0 plus path and uid patches to use lizardfs for paths and users
UIDs and GIDs patch attached.
Comment 1 Michal Bielicki 2018-01-27 12:24:51 UTC
Created attachment 190107 [details]
UIDs patch to add user lizardfs
Comment 2 Michal Bielicki 2018-01-27 12:25:22 UTC
Created attachment 190108 [details]
GIDs patch to add group lizardfs
Comment 3 Tobias Kortkamp freebsd_committer 2018-01-27 20:41:21 UTC
Please also put this up on https://reviews.freebsd.org/.  It's too large to
comfortably review on Bugzilla.

https://wiki.freebsd.org/Phabricator
Comment 4 Michal Bielicki 2018-01-27 23:51:19 UTC
(In reply to Tobias Kortkamp from comment #3)

You Shall Not Pass: Projects	
You do not have permission to create new projects.
Users with the "Can Create Projects" capability:
Administrators can take this action.
Comment 5 Michal Bielicki 2018-01-27 23:54:10 UTC
Another question is what is too big. The attached patch is taken from our own gerrit repo (http://cr.skytechnology.pl:8081/#/c/2850/) and just translated with make makepatch to comply with what portlint says.
Comment 6 Marin Bernard 2018-04-14 11:58:03 UTC
(In reply to Michal Bielicki from comment #5)
Hi Michal,

Please, upload a diff to Phabricator for code review. The link provided by Tobias Kortkamp includes detailed instructions about how to do that.

If you want to use the web UI, you may jump directly to https://wiki.freebsd.org/Phabricator%20#Create_a_Revision_via_Web_Interface.

I can't want to use LizardFS on FreeBSD!
Comment 7 florian.heigl 2018-04-16 20:19:59 UTC
I dunno, but maybe it would help to answer him about the missing permissions instead of asking again that he uploads? :))
Comment 8 Marin Bernard 2018-04-16 20:31:08 UTC
(In reply to florian.heigl from comment #7)
I would, but I think permissions are fine:
https://reviews.freebsd.org/differential/diff/create/
Comment 9 Tobias Kortkamp freebsd_committer 2018-11-29 13:10:44 UTC
(In reply to Michal Bielicki from comment #4)
You need to create a Differential Revision not a Project.

> Another question is what is too big.

The shar is 304kb and it will be confusing for all parties if I start posting
inline comments here on Bugzilla.
Comment 10 florian.heigl 2018-11-29 13:44:07 UTC
By now Michal and I try to align our business trips, so we can meet up somewhere in Europe just so we can somehow get through the hoops based on a bit of advice dropped months or almost-years later.

is there a requirement that Michal does the phabricator upload personally, or can someone else just do that?

please rest assured, 'confusion' is the least concern here, and a lot more confusion is caused by how this contrib has been (not) going.
Comment 11 Tobias Kortkamp freebsd_committer 2018-11-29 15:24:49 UTC
(In reply to florian.heigl from comment #10)
> please rest assured, 'confusion' is the least concern here, and
> a lot more confusion is caused by how this contrib has been (not)
> going.

Agreed.
Comment 12 Tobias Kortkamp freebsd_committer 2019-02-11 08:23:48 UTC
Apparently added independently by jhixson@ in ports r491834.