Bug 226791

Summary: databases/postgresql10-server: krb5 radio option also for this version?
Product: Ports & Packages Reporter: david
Component: Individual Port(s)Assignee: pgsql
Status: New ---    
Severity: Affects Only Me CC: w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (pgsql)
Version: Latest   
Hardware: Any   
OS: Any   

Description david 2018-03-19 21:46:55 UTC
(this actually applies to lots of the postgresql ports, but I will focus on 10).

If you wish to install with _MIT_ kerberos (and you don't have heimdal on your system), it will not build (I cannot comment on other configs, like you want MIT and you have heimdal).

The problem is that "awhile" ago certain config options were locked away behind checks for postgresql version 9.2; If I remove the .IF/.ENDIF on makefile lines 110 and 113 it all works as expected; this was added in: 447678 included as part of a point release with no other explanation in the commit messages that I saw; be great to no longer maintain these changes locally