Bug 227423

Summary: graphics/wayland: update to 1.16 (libwayland-egl NOW LIVES HERE!)
Product: Ports & Packages Reporter: Greg V <greg>
Component: Individual Port(s)Assignee: freebsd-x11 mailing list <x11>
Status: Closed FIXED    
Severity: Affects Only Me CC: dpolyg, greg, jbeich, johalun0, pkubaj, zeising
Priority: --- Flags: bugzilla: maintainer-feedback? (x11)
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 237650, 222175, 224202, 227509, 230298    
Attachments:
Description Flags
wayland-1.15.patch
none
wayland-1.16.patch none

Description Greg V 2018-04-10 16:03:12 UTC
Created attachment 192393 [details]
wayland-1.15.patch

https://lists.freedesktop.org/archives/wayland-devel/2018-April/037767.html

The biggest change:

> libwayland-egl is now part of libwayland, and will presumably be removed
from mesa in the not too distant future.

This is good news for us! All ports that depend on libwayland-egl can now enable Wayland by default, independently of what happens in the Mesa port.

(Wayland-EGL *working* still requires building Mesa with the Wayland platform, but only rebuilding Mesa instead of every UI toolkit is significantly easier.)
Comment 1 Niclas Zeising freebsd_committer 2018-05-16 13:42:29 UTC
I'm aware of this patch, will look as time permits.
Comment 2 Denis Polygalov 2018-08-08 11:26:10 UTC
+me on this. Willing to test when it will be available.

Also related information:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227509
Comment 3 Greg V 2018-10-12 22:29:20 UTC
Created attachment 198077 [details]
wayland-1.16.patch

Update to 1.16.
Comment 4 Denis Polygalov 2018-10-14 04:10:04 UTC
(In reply to Greg V from comment #3)

Hi Greg,

this patch does not remove WAYLAND compile option from
the graphics/mesa-libs neither put it into OPTIONS_DEFAULT...

Does it mean that we still need to re-compile graphics/mesa-libs
from ports with WAYLAND enabled in order to use Wayland-related
ports such as Weston?

Regards,
Denis
Comment 5 Greg V 2018-10-14 09:00:42 UTC
(In reply to Denis Polygalov from comment #4)
Yes, I mentioned that in the first post here:

> (Wayland-EGL *working* still requires building Mesa with the Wayland platform, > but only rebuilding Mesa instead of every UI toolkit is significantly easier.)
Comment 6 Denis Polygalov 2018-10-15 02:05:25 UTC
(In reply to Greg V from comment #5)
Hi Greg,

thanks for the patch and clarification.
I'm aware about the statement in your first post just seems like
I don't understand all the dependencies. 

By comparing outputs of 'pkg info mesa-libs' of mesa-libs compiled 
with and without WAYLAND option I can see that the only difference
in "Shared Libs provided" section is presence of libwayland-egl.so.1,
meaning that mesa-libs compiled with WAYLAND option set to ON provide
that extra library only.

Lines in your patch such as:
-WAYLAND_LIB_DEPENDS=	libwayland-egl.so:graphics/mesa-libs
+WAYLAND_LIB_DEPENDS=	libwayland-egl.so:graphics/wayland

gave me impression that the libwayland-egl.so.1 moved
to graphics/wayland therefore the WAYLAND compile option
can be excluded from mesa-libs but seems like things are 
more complicated than I thought...

Regards,
Denis.
Comment 7 commit-hook freebsd_committer 2018-10-16 00:00:16 UTC
A commit references this bug:

Author: jbeich
Date: Mon Oct 15 23:59:28 UTC 2018
New revision: 482189
URL: https://svnweb.freebsd.org/changeset/ports/482189

Log:
  graphics/wayland: update to 1.16.0

  - New libwayland-egl home for consumers as Mesa 18.2 dropped it

  Changes:	https://lists.freedesktop.org/archives/wayland-devel/2018-April/037767.html
  Changes:	https://lists.freedesktop.org/archives/wayland-devel/2018-August/039358.html
  PR:		227423
  Submitted by:	Greg V <greg@unrelenting.technology>
  Approved by:	maintainer timeout (5 months)

Changes:
  head/devel/efl/Makefile
  head/graphics/glfw/Makefile
  head/graphics/mesa-libs/Makefile
  head/graphics/mesa-libs/pkg-plist
  head/graphics/qt5-wayland/Makefile
  head/graphics/vulkan-loader/Makefile
  head/graphics/wayland/Makefile
  head/graphics/wayland/distinfo
  head/graphics/wayland/files/patch-Makefile.am
  head/graphics/wayland/files/patch-configure.ac
  head/graphics/wayland/files/patch-src_wayland-server.c
  head/graphics/wayland/files/patch-src_wayland-shm.c
  head/graphics/wayland/files/patch-tests_sanity-test.c
  head/graphics/wayland/files/patch-tests_test-helpers.c
  head/graphics/wayland/files/patch-tests_test-runner.c
  head/graphics/wayland/pkg-plist
  head/graphics/waylandpp/Makefile
  head/www/webkit2-gtk3/Makefile
  head/x11-toolkits/gtk30/Makefile
Comment 8 commit-hook freebsd_committer 2018-10-16 00:00:19 UTC
A commit references this bug:

Author: jbeich
Date: Mon Oct 15 23:59:55 UTC 2018
New revision: 482190
URL: https://svnweb.freebsd.org/changeset/ports/482190

Log:
  graphics/vulkan-loader: enable Wayland surface

  - Rebuild ppsspp and rpcs3 to pick up Wayland support for Vulkan

  PR:		227423
  Submitted by:	Greg V (maintainer)

Changes:
  head/emulators/ppsspp/Makefile
  head/emulators/rpcs3/Makefile
  head/graphics/vulkan-loader/Makefile
Comment 9 Jan Beich freebsd_committer 2018-10-16 00:02:12 UTC
Thanks. Landed. I've left out some unrelated bits:
- libwayland-egl in mesa-libs needs @comment until 18.2 to avoid stage-qa warnings
- pkg-plist change in wayland-protocols was breaking build

WAYLAND isn't globally enabled yet, so an exp-run wasn't necessary due to possible false positives (e.g., bug 226408 comment 3, bug 232299). For one, libwayland-egl cannot be accidentally picked up because graphics/wayland isn't pulled as a dependency by default.
Comment 10 Greg V 2018-10-16 09:46:37 UTC
(In reply to Denis Polygalov from comment #6)
Yeah, libwayland-egl moved, but Mesa still needs to be built with WAYLAND enabled because that also enables actual Wayland support in libEGL and others
Comment 11 Jan Beich freebsd_committer 2018-10-20 23:12:37 UTC
*** Bug 231765 has been marked as a duplicate of this bug. ***