Bug 227869

Summary: Backlight brightness media keys are not working on Lenovo B570e (although backlight brightness can be controlled via intel_backlight)
Product: Base System Reporter: Account Removed <mike.d.ft402>
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: Closed Not Enough Information    
Severity: Affects Only Me CC: 0mp, danfe, emaste
Priority: --- Keywords: needs-qa
Version: 11.1-RELEASE   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Verbose boot dmesg.
none
ACPI errors none

Description Account Removed 2018-04-30 12:46:25 UTC
Created attachment 192927 [details]
Verbose boot dmesg.

I'm aware that to control backlight you have to use graphics/intel-backlight (is there any chance to see this exposed to sysctl in the future without needing this kludge?) -- and it works if I bind it to some window manager keys.

However, I can not use the brightness keys via window manager nor devd, because they generate no events at all. I have tried loading different acpi_* kernel modules, and none of them work.
Comment 1 Account Removed 2018-04-30 12:50:20 UTC
This has always been the case, since version 9, and I have not used any earlier version.
Comment 2 Account Removed 2018-04-30 12:50:53 UTC
Created attachment 192928 [details]
ACPI errors

These errors show up at random, are they relevant?
Comment 3 Account Removed 2018-04-30 16:27:01 UTC
I forgot to add: brightness works up until the kernel is loader. And the brightness set by intel-backlight does not survive suspend restore -- it is reset to the pre-kernel setting.
Comment 4 Account Removed 2018-04-30 16:27:18 UTC
is loaded*
Comment 5 Alexey Dokuchaev freebsd_committer 2020-10-01 03:09:30 UTC
> is there any chance to see this exposed to sysctl in the future without needing
> this kludge? [...] I have tried loading different acpi_* kernel modules, and
> none of them work.
On the Lenovo L470 here and fairly recent -CURRENT I can control brightness with sysctl(8) after loading acpi_video(4) module.  Also, as of base r360025 brightness change events are visible via devd(8):

> # sysctl hw.acpi.video.lcd0.brightness=85
> hw.acpi.video.lcd0.brightness: 60 -> 85
> 
> $ cat /var/run/devd.pipe
> 
> !system=ACPI subsystem=Video type=brightness notify=85
Your report was against 11.1-RELEASE which is no longer supported.  Could you please update to contemporary, supported FreeBSD version and reconduct your tests?
Comment 6 Account Removed 2021-09-26 11:47:50 UTC
Sorry, have not been using FreeBSD for a long time.
Comment 7 Mateusz Piotrowski freebsd_committer 2021-09-26 18:43:09 UTC
(In reply to Account Removed from comment #6)
Thank you for the report anyway! 

Let's reopen this issue if it turns out that the problem is still present.