Bug 229814

Summary: devel/arduino18: update to 1.8.5
Product: Ports & Packages Reporter: Christoph Moench-Tegeder <cmt>
Component: Individual Port(s)Assignee: Christoph Moench-Tegeder <cmt>
Status: Closed FIXED    
Severity: Affects Only Me Keywords: easy, patch, patch-ready
Priority: --- Flags: bugzilla: maintainer-feedback? (kevans)
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=225481
Attachments:
Description Flags
update arduino18 to 1.8.5
none
update arduino18 to 1.8.5 kevans: maintainer-approval+

Description Christoph Moench-Tegeder freebsd_committer 2018-07-16 22:28:33 UTC
Created attachment 195182 [details]
update arduino18 to 1.8.5

update arduino18 to current release. Also updates embedded libraries to versions listed in Arduino's build.xml:
  * Firmata: 2.5.6
  * Robot_Control: 1.0.4
  * Robot_Motor: 1.0.3
  * RobotIRremote: 2.0.0
  * Temboo: 1.2.1

Additionally, LiquidCrystal has been moved out of Arduino.

This does not address bug #225481 .

Passes poudriere and general run test.
Comment 1 Kyle Evans freebsd_committer 2018-07-16 22:46:07 UTC
(In reply to Christoph Moench-Tegeder from comment #0)

Hi,

Was there anything here that required a core updated? I was mostly waiting on figuring that out and straightening out the core situation since AVR got moved out, but getting things done in time for releases left me with ENOTIME.
Comment 2 Christoph Moench-Tegeder freebsd_committer 2018-07-17 10:28:33 UTC
(In reply to Kyle Evans from comment #1)

There's nothing which requires an update (aside from me being a follower of the keep-it-close-to-upstream philosophy). Mostly this is the result of a debug session, after which I had to accept (after upgrading everything to "latest") that one of my Unos might be slightly bricked... I just wanted to avoid losing the patch. I also poked at libserialport and listserialc, and could just barely surpress the urge to rewrite that.
Comment 3 Kyle Evans freebsd_committer 2018-07-17 11:46:42 UTC
(In reply to Christoph Moench-Tegeder from comment #2)

Sorry, I didn't actually need that much justification. =P I just wanted to make sure this works with the current development/arduino-core without issue.

When you say one of your Uno's might be bricked- what are you experiencing? I have a tentative patch locally for the constantly resetting stuff, but I was waiting on some feedback that I don't seem to be getting.
Comment 4 Christoph Moench-Tegeder freebsd_committer 2018-07-17 12:20:22 UTC
(In reply to Kyle Evans from comment #3)

It looks like it's "working" - that is, I can compile ("verify") at least simple sketches. I didn't test much more of this (hey, this is a minor release...).

The Uno is "bricked" by having it's USB somewhat wrecked: it doesn't show up in "usbconfig list", uarduno.ko does not pick it up, and I guet a cuau* device (instead of cuaU* - mind the upper-case U). A linux box complains about "device is not responding to setup address" - in summary, this clearly looks like breakage on the Uno's side (and may have been caused by me pushing a garbage-IHEX across  when experimenting with avr-gcc and avrdude). I'll try re-flashing the bootloader when I get the time for that (ENOTIME being a problem here, too).
Comment 5 Kyle Evans freebsd_committer 2018-07-17 13:19:35 UTC
(In reply to Christoph Moench-Tegeder from comment #4)

Ok, diff looks mostly good- arduino/lib/jssc-2.8.0-arduino1.jar needs to be removed from the pkg-plist and "${RM} ${STAGEDIR}${PREFIX}/${PORTNAME}/lib/jssc-2.8.0.jar" in do-install needs to be updated with the new name. Their change to make it -arduino1 [1] doesn't look applicable to us, but if we run into problems with what we have now we should patch comms/java-simple-serial-connector for it.

Also, FYI- it won't fix your problem, but uarduno may be replaced with umodem(4) in base as of sometime in the 10.x series.

Thanks,

Kyle Evans

[1] https://github.com/scream3r/java-simple-serial-connector/pull/105
Comment 6 Christoph Moench-Tegeder freebsd_committer 2018-07-17 19:53:42 UTC
Created attachment 195211 [details]
update arduino18 to 1.8.5

ok, here it is. still seems to pass.
Comment 7 Christoph Moench-Tegeder freebsd_committer 2018-07-17 19:54:57 UTC
(In reply to Kyle Evans from comment #5)

Um, I'm on 11 (FreeBSD 11.2, to be precise) and uarduno "still works" (or at least seems to work) with my non-bricked Uno (knowing me and my track record with hardware... redundancy is key)
Comment 8 Kyle Evans freebsd_committer 2018-07-17 19:57:40 UTC
(In reply to Christoph Moench-Tegeder from comment #7)

Right, uarduno still works, but it was built in a time when base didn't have a functional umodem(4) to work with CDC-ACM devices -- just saying you can drop it if you'd like in favor of umodem(4), since the author and maintainer seems to have also done this.

Patch looks good. Thanks! =)
Comment 9 commit-hook freebsd_committer 2018-07-18 11:43:49 UTC
A commit references this bug:

Author: cmt
Date: Wed Jul 18 11:43:19 UTC 2018
New revision: 474855
URL: https://svnweb.freebsd.org/changeset/ports/474855

Log:
  devel/arduino18: update to 1.8.5

  Also update embedded libraries according to Arduino's build.xml:
    * Firmata: 2.5.6
    * Robot_Control: 1.0.4
    * Robot_Motor: 1.0.3
    * RobotIRremote: 2.0.0
    * Temboo: 1.2.1
  and add external LiquidCrystal, as it has been removed from Arduino
  itself.

  PR:		229814
  Approved by:	kevans@ (maintainer)

Changes:
  head/devel/arduino18/Makefile
  head/devel/arduino18/distinfo
  head/devel/arduino18/files/patch-build_build.xml
  head/devel/arduino18/pkg-plist
Comment 10 Christoph Moench-Tegeder freebsd_committer 2018-07-18 11:45:06 UTC
comitted as ports r474855 - thanks!