Bug 230164

Summary: databases/py-alembic: change dependency from sqlalchemy10 to sqlalchemy12
Product: Ports & Packages Reporter: Kurt Jaeger <pi>
Component: Individual Port(s)Assignee: Li-Wen Hsu <lwhsu>
Status: Closed FIXED    
Severity: Affects Only Me CC: sunpoet, vishwin
Priority: --- Flags: pi: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 225543    
Attachments:
Description Flags
patch none

Description Kurt Jaeger freebsd_committer 2018-07-29 20:02:19 UTC
Created attachment 195609 [details]
patch

Testbuilds look ok.
Comment 1 commit-hook freebsd_committer 2018-07-31 13:22:51 UTC
A commit references this bug:

Author: lwhsu
Date: Tue Jul 31 13:21:49 UTC 2018
New revision: 476001
URL: https://svnweb.freebsd.org/changeset/ports/476001

Log:
  Change dependency from sqlalchemy10 to sqlalchemy12 because mail/mailman3 needs

  PR:		230164
  Submitted by:	pi

Changes:
  head/databases/py-alembic/Makefile
Comment 2 Po-Chuan Hsieh freebsd_committer 2018-08-04 15:27:37 UTC
FYI, only devel/py-oslo.db and www/py-flask-migrate depend on this port.
And devel/py-oslo.db is broken now.

Some of the dependencies of py-oslo.db:
- py-alembic (depends on py-sqlalchemy12 now)
- py-sqlalchemy-migrate (depends on py-sqlalchemy10)
- py-sqlalchemy10

Reported by:    pkg-fallout
Reference:      http://beefy11.nyi.freebsd.org/data/head-i386-default/p476329_s337279/logs/py36-oslo.db-4.40.0.log
Comment 3 Kurt Jaeger freebsd_committer 2018-08-05 07:18:02 UTC
py-sqlalchemy-migrate builds with 12 just a well, maybe time to update that depends list ? py-oslo.db builds with 12, too. Both probably need runtests,
but updating the depends to 12 does not seem too far away.