Bug 230689

Summary: lang/opencoarrays: Update to 2.2.0
Product: Ports & Packages Reporter: Anton Shterenlikht <as>
Component: Individual Port(s)Assignee: Steve Wills <swills>
Status: Closed FIXED    
Severity: Affects Only Me CC: fernape
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=228814
Description Flags
svn diff
svn diff
koobs: maintainer-approval+
All tests pass with GCC8
But yes, many failures with GCC7 none

Description Anton Shterenlikht 2018-08-17 09:57:49 UTC
Created attachment 196274 [details]
svn diff

All tests pass with MPICH and OpenMPI.
OpenMPI2 - some tests seem to hang, still
because MPICH is the default, I think the port
is ready.

This PR makes
Comment 1 Anton Shterenlikht 2018-08-17 10:13:21 UTC
Note that running tests *as root* is still causing a hang:
Comment 2 Anton Shterenlikht 2018-08-17 14:07:15 UTC
Created attachment 196287 [details]
svn diff

Forgot to bump SOVERSION for gcc8.
Comment 3 Fernando ApesteguĂ­a freebsd_committer 2018-08-17 16:23:37 UTC
I applied the patch and build lang/opencoarrays 2.2.0 without problems in 11.2.

I ran make test both as regular user and as root. A lot of tests failed but the system didn't hang up.

Funny enough, building in 11.1{amd64,i386} in a jailed environment pass the tests when executed as root. It does not produce a hang either.
Comment 4 Anton Shterenlikht 2018-08-19 09:16:08 UTC
Created attachment 196338 [details]
All tests pass with GCC8
Comment 5 Anton Shterenlikht 2018-08-19 09:16:41 UTC
Created attachment 196339 [details]
But yes, many failures with GCC7
Comment 6 Anton Shterenlikht 2018-08-19 09:17:44 UTC
I'll report this upstream
Comment 7 commit-hook freebsd_committer 2018-08-19 12:54:55 UTC
A commit references this bug:

Author: swills
Date: Sun Aug 19 12:54:10 UTC 2018
New revision: 477570
URL: https://svnweb.freebsd.org/changeset/ports/477570

  lang/opencoarrays update to 2.2.0

  PR:		230689
  Submitted by:	Anton Shterenlikht <as@cmplx.uk> (maintainer)

Comment 8 Steve Wills freebsd_committer 2018-08-19 12:55:14 UTC
Committed, thanks!
Comment 9 Anton Shterenlikht 2018-08-19 13:43:45 UTC
Unfortunately it seems you applied the old (obsolete) patch.
The correct patch is in attachment
See comment 2

Comment 10 Fernando ApesteguĂ­a freebsd_committer 2018-08-19 16:13:09 UTC
(In reply to Steve Wills from comment #8)

Why did we commit this patch? Shouldn't the problem with the tests be solved before proceeding with it?

It still fails in my machine (11.2 amd64).
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-20 02:34:21 UTC
Comment on attachment 196287 [details]
svn diff

Correctly set maintainer approval
Comment 12 Anton Shterenlikht 2018-08-20 10:43:08 UTC

upstream PR, for easy reference
Comment 13 Steve Wills freebsd_committer 2018-08-20 18:42:24 UTC
I was under the mistaken impression the issue was an issue with the tests themselves. Should I go ahead and commit the rest of the change or wait for a complete fix?
Comment 14 Anton Shterenlikht 2018-08-21 13:37:58 UTC
I think the issue is indeed "with the tests themselves".
I'm dealing with the upstream to investigate.
I bet that after switching to GCC8, they haven't tested
much with GCC7, hence the failures.

I'd prefer to commit the rest of the patch now,
as it is the correct patch.
Comment 15 commit-hook freebsd_committer 2018-08-22 14:59:28 UTC
A commit references this bug:

Author: swills
Date: Wed Aug 22 14:58:56 UTC 2018
New revision: 477793
URL: https://svnweb.freebsd.org/changeset/ports/477793

  lang/opencoarrays: Commit missed part of patch

  PR:		230689
  Submitted by:	Anton Shterenlikht <as@cmplx.uk> (maintainer)
  Reported by:	Anton Shterenlikht <as@cmplx.uk> (maintainer)
  Pointyhat to:	swills

Comment 16 Steve Wills freebsd_committer 2018-08-22 15:01:45 UTC
Great, committed the rest, sorry for the mistake.