Bug 231228

Summary: devel/llvm[4567]0: : CommandLine Error: Option 'enable-value-profiling' registered more than once!
Product: Ports & Packages Reporter: O. Hartmann <ohartmann>
Component: Individual Port(s)Assignee: Brooks Davis <brooks>
Status: Closed DUPLICATE    
Severity: Affects Many People CC: FreeBSD, x11
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description O. Hartmann 2018-09-07 14:51:36 UTC
In case several OpenCL implementations sharing devel/LLVM > LLVM 3.X are installed, software compiled with the OpenCL backend will fail with an error like:

Device open failed, aborting...
: CommandLine Error: Option 'enable-value-profiling' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options
Nothing to output !

(the error message above has been taken from clinfo, see Bug 231226).

This problem seems to be unresolved in LLVM, although known since a couple of years for now. See, for instance, Bug 219562, Bug 224584 where I tried to gather some of the bug reports on LLVM.

In case devel/ocl-icd is installed, graphics/blender seem to fail when compiled using OpenCL and option CYCLES - calling blender results in the same error as shown above.

To reproduce the error described here, try to have installed mesa,beignet as well as devel/clinfo and devel/ocl-icd and/or lang/pocl.

devel/clinfo reveals the problem quickly.

lang/pocl is useless if used with an ICD.

Can someone help on this?

Kind regards,

oh
Comment 1 Brooks Davis freebsd_committer 2019-01-10 05:11:10 UTC

*** This bug has been marked as a duplicate of bug 233495 ***