Bug 231271

Summary: databases/p5-DBD-mysql: update 4.046 -> 4.047
Product: Ports & Packages Reporter: Kurt Jaeger <pi>
Component: Individual Port(s)Assignee: Sunpoet Po-Chuan Hsieh <sunpoet>
Status: Closed FIXED    
Severity: Affects Only Me CC: dewayne, pi, sascha
Priority: --- Flags: bugzilla: maintainer-feedback? (perl)
Version: Latest   
Hardware: Any   
OS: Any   
URL: https://metacpan.org/changes/distribution/DBD-mysql
Attachments:
Description Flags
patch none

Description Kurt Jaeger freebsd_committer 2018-09-09 18:45:49 UTC
Created attachment 196990 [details]
patch

testbuilds are fine with:
12a, mysql=10.3m
11.2a, mysql=10.3m
11.1a, mysql=10.1m
10.4i, mysql=5.6.41
Comment 1 dewayne 2018-09-11 02:50:44 UTC
(In reply to Kurt Jaeger from comment #0)
Unfortunately 4.047 fails with mariadb-10.3 (on FreeBSD 11.2S i386 & amd64) using clang 6.0.1 or gcc8.2. I suspect that the update to the port missed the files/patch-dbimp.c  =:-0

When the patch is applied, the following goes away ;)

--- dbdimp.o ---
In file included from /usr/local/include/mysql/mysql.h:60,
                 from dbdimp.h:21,
                 from dbdimp.c:15:
dbdimp.c: In function 'mysql_dr_connect':
/usr/local/include/mysql/mariadb_version.h:14:31: error: token ""mariadb-10.3"" is not valid in preprocessor expressions
 #define MARIADB_BASE_VERSION  "mariadb-10.3"
                               ^~~~~~~~~~~~~~
dbdimp.c:1910:56: note: in expansion of macro 'MARIADB_BASE_VERSION'
 #if (MYSQL_VERSION_ID >= 50723) && (MYSQL_VERSION_ID < MARIADB_BASE_VERSION)
                                                        ^~~~~~~~~~~~~~~~~~~~
/usr/local/include/mysql/mariadb_version.h:14:31: error: token ""mariadb-10.3"" is not valid in preprocessor expressions
 #define MARIADB_BASE_VERSION  "mariadb-10.3"
                               ^~~~~~~~~~~~~~
dbdimp.c:1917:56: note: in expansion of macro 'MARIADB_BASE_VERSION'
 #if (MYSQL_VERSION_ID >= 50600) && (MYSQL_VERSION_ID < MARIADB_BASE_VERSION)
                                                        ^~~~~~~~~~~~~~~~~~~~
dbdimp.c: In function 'mysql_st_prepare':
dbdimp.c:3200:24: warning: assignment to 'my_bool *' {aka 'char *'} from incompatible pointer type '_Bool *' [-Wincompatible-pointer-types]
           bind->is_null=      (_Bool*) &(fbind->is_null);
                        ^
*** [dbdimp.o] Error code 1

make[1]: stopped in /var/ports/usr/ports/databases/p5-DBD-mysql/work/DBD-mysql-4.047
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-09-11 18:55:54 UTC
*** Bug 231299 has been marked as a duplicate of this bug. ***
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-09-11 19:01:36 UTC
Committed. Thanks!
Comment 4 commit-hook freebsd_committer 2018-09-11 19:02:16 UTC
A commit references this bug:

Author: sunpoet
Date: Tue Sep 11 19:01:26 UTC 2018
New revision: 479564
URL: https://svnweb.freebsd.org/changeset/ports/479564

Log:
  Fix build with MariaDB

  PR:		231271
  Submitted by:	pi

Changes:
  head/databases/p5-DBD-mysql/files/
  head/databases/p5-DBD-mysql/files/patch-dbdimp.c