Bug 231656

Summary: /etc/nsmb.conf requires workgroup and user names to be UPPERCASE, while mount_smbfs not.
Product: Base System Reporter: Gleb Popov <arrowd>
Component: binAssignee: freebsd-bugs mailing list <bugs>
Status: New ---    
Severity: Affects Only Me CC: yuripv
Priority: ---    
Version: 11.2-RELEASE   
Hardware: Any   
OS: Any   

Description Gleb Popov freebsd_committer 2018-09-24 09:20:58 UTC
When I run

mount_smbfs -I 172.16.34.25 //user@host/Cloud /mnt

it prompts me to enter a password and then successfully mounts the share.

However, putting

[host:user]
password=123123

into /etc/nsmb.conf and then running

mount_smbfs -N -I 172.16.34.25 //user@host/Cloud /mnt

doesn't work due to failing authentication.

I've sniffed packets and it turned out that mount_smbfs sends different hashes used to authenticate. After a bit of googling I found advice to write all SMB resource names in uppercase and it worked. After changing nsmb.conf contents to

[HOST:USER]
password=123123

the command with -N finally worked out.

Is it a bug, or I'm just misundestanding something?
Comment 1 Yuri Pankov freebsd_committer 2018-11-17 08:00:40 UTC
/etc/nsmb.conf actually mentions the requirement, nsmb.conf(5) doesn't though:

...
# SMB library uses next forms of section names (please note that the section
# name should be in upper case when it refers to server, user or share):
...
Comment 2 Gleb Popov freebsd_committer 2019-06-08 07:48:24 UTC
(In reply to Yuri Pankov from comment #1)

Even if man page had mentioned this behavior, I still think it is not enough visible for a user.

Can we just error out in mount_smbfs when config file has lowercase letters in section names?