Bug 231725

Summary: [ZFS] cannot disable vfs.zfs.compressed_arc_enabled on 10.4-RELEASE
Product: Base System Reporter: Carlossrp <carlos.poita>
Component: miscAssignee: freebsd-fs mailing list <fs>
Status: Open ---    
Severity: Affects Many People CC: smh
Priority: --- Keywords: regression
Version: 10.4-RELEASE   
Hardware: amd64   
OS: Any   
Description Flags
Adds missing vfs.zfs.compressed_arc_enabled tunable none

Description Carlossrp 2018-09-25 19:55:25 UTC
Dear FreeBSD Bugzilla community,

I'm having some kernel panics on one production server after updating FreeBSD from 10.3-RELEASE to 10.4-RELEASE.

I noticed that vfs.zfs.compressed_arc_enabled appeared in 10.4-RELEASE, and this feature make FreeBSD unstable in our VMware ESXi 6.0 environment. We had some issues with 11.x in the past, and as a workaround, we switched back to 10.3-RELEASE.

More details in this thread I opened in the community forum: https://forums.freebsd.org/threads/kernel-panic-after-upgrading-to-11-1.62499/

I tried to set: vfs.zfs.compressed_arc_enabled="0" in /boot/loader.conf but the parameter keeps "1" after reboot.

I tried the same on a fresh 11.2-RELEASE server and the configuration was successful.

Can we have a look at this?

Comment 1 Steven Hartland freebsd_committer 2018-09-26 07:39:45 UTC
Just tested this on 11.2-RELEASE-p3 and setting to zero in loader.conf works fine:
grep compressed_arc_enabled /boot/loader.conf 

sysctl vfs.zfs.compressed_arc_enabled
vfs.zfs.compressed_arc_enabled: 0

Please check you don't have a syntax error in your loader.conf
Comment 2 Carlossrp 2018-09-26 11:06:51 UTC
Hi Steven!

You're right, this works on 11.2-RELEASE.

I'm having trouble setting on 10.4-RELEASE.

More specifically, 10.4-RELEASE-p12, which is the version our 10.3-RELEASE box was updated to.

I've successfully reproduced this with offical AWS Marketplace images too, works with 11.2-RELEASE-p3 but not with 10.4-RELEASE-p12.

Comment 3 Steven Hartland freebsd_committer 2018-09-26 11:22:53 UTC
Created attachment 197509 [details]
Adds missing vfs.zfs.compressed_arc_enabled tunable

Confirmed looks like an issue with the change when it was back ported to 10.4 which doesn't support CTLFLAG_xxTUN flags to enable tunables it needs manually adding with a TUNABLE_xxx call.

Patch attached.
Comment 4 Carlossrp 2018-09-26 22:16:06 UTC
Hi Steven,

I've successfully tested the patch on 10.4-RELEASE-p12.

Changed the file then rebuilt world and kernel.

I believe we can close this,