Bug 231730

Summary: sysutils/consolekit2: Add polkit build option
Product: Ports & Packages Reporter: Ali Abdallah <ali.abdallah>
Component: Individual Port(s)Assignee: Steve Wills <swills>
Status: Closed FIXED    
Severity: Affects Only Me CC: desktop, koobs, lwhsu, samy.mahmoudi, swills, tcberner
Priority: --- Keywords: easy, feature, needs-qa
Version: LatestFlags: koobs: merge-quarterly?
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=234919
Attachments:
Description Flags
Add option for building with/without polkit
none
updated patch tcberner: maintainer-approval+

Description Ali Abdallah 2018-09-26 10:37:47 UTC
Created attachment 197505 [details]
Add option for building with/without polkit
Comment 1 Ali Abdallah 2020-06-04 08:46:29 UTC
Ping, any way to get this patch included?
Comment 2 Samy Mahmoudi 2020-06-11 12:38:54 UTC
Hi,

Did you try sending a mail asking commit under maintainer timeout? Here is the pattern I use in such cases:

Address: ports@freebsd.org

Subject:
[patch] [maintainer timeout, ~20 months] bug 231730 - sysutils/consolekit2: add polkit build option

Body:
Dear committer,

Could you please commit the changes associated with the patch file of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231730 ?

Best regards,
Comment 3 Samy Mahmoudi 2020-06-11 12:54:45 UTC
Please also see comment 7 of bug 234919.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-26 09:01:41 UTC
Hi Ali,

Does the present patch still apply against ports head?
Comment 5 Ali Abdallah 2020-06-26 09:07:08 UTC
(In reply to Kubilay Kocak from comment #4)

I just checked on the 2020Q2 branch and it still applies, last update was on 07 Nov 2019, so it applies also to head.
Comment 6 Tobias C. Berner freebsd_committer 2020-11-15 10:33:01 UTC
@swills, you were looking at similar changes recently, could you take this one?

mfg Tobias
Comment 7 Steve Wills freebsd_committer 2020-12-16 15:13:26 UTC
Created attachment 220622 [details]
updated patch
Comment 8 Steve Wills freebsd_committer 2020-12-16 15:13:41 UTC
*** Bug 250544 has been marked as a duplicate of this bug. ***
Comment 9 Tobias C. Berner freebsd_committer 2020-12-17 15:32:44 UTC
Comment on attachment 220622 [details]
updated patch

Ship it!


mfg Tobias
Comment 10 commit-hook freebsd_committer 2020-12-17 16:03:20 UTC
A commit references this bug:

Author: swills
Date: Thu Dec 17 16:03:06 UTC 2020
New revision: 558300
URL: https://svnweb.freebsd.org/changeset/ports/558300

Log:
  sysutils/consolekit2: Add polkit build option

  PR:		231730
  Submitted by:	Ali Abdallah <ali.abdallah@suse.com> (original version)
  Approved by:	desktop@ (tcberner)

Changes:
  head/sysutils/consolekit2/Makefile
  head/sysutils/consolekit2/pkg-plist
Comment 11 Steve Wills freebsd_committer 2020-12-17 16:04:21 UTC
Committed, thanks!