Bug 232523

Summary: www/otrs: error: Kernel::System::XML::Simple could not be loaded
Product: Ports & Packages Reporter: O. Hartmann <ohartmann>
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed DUPLICATE    
Severity: Affects Many People CC: m.tsatsenko
Priority: --- Flags: bugzilla: maintainer-feedback? (m.tsatsenko)
Version: Latest   
Hardware: Any   
OS: Any   

Description O. Hartmann 2018-10-22 09:57:48 UTC
Trying to install OTRS (www/otrs) on FreeBSD 11.2-RELENG-p4 (amd64) fails when trying to configure for the first time via web interface (see below). After the pkg installation of the software I followed the the instructions to properly set the access rights on the tree and setup of the PostgreSQL DB tables. After providing the proper informations for the DB setup and after those have been finished successfully, the error shown below pops up in the httpd-error.log after proceeding. In the firefox' windows there is shown an "Internal server error 500".

[...]
[Mon Oct 22 09:43:13 2018] -e: BEGIN failed--compilation aborted at /usr/local/otrs/Kernel/System/XML/Simple.pm line 14.
[Mon Oct 22 09:43:13 2018] -e: Compilation failed in require at /usr/local/otrs/Kernel/System/ObjectManager.pm line 254.
[Mon Oct 22 09:43:13 2018] -e:  at /usr/local/otrs/Kernel/System/SysConfig/XML.pm line 129.
[Mon Oct 22 09:43:13.314730 2018] [:error] [pid 2491:tid 35058361088] Kernel::System::XML::Simple could not be loaded: Can't locate XML/LibXML/Simple.pm in @INC (you may need to install the XML::LibXML::Simple module) (@INC contains: /usr/local/Custom /usr/local/Kernel/cpan-lib /usr/local /usr/local/sbin/../../Custom /usr/local/sbin/../../Kernel/cpan-lib /usr/local/sbin/../.. /usr/local/otrs/Custom /usr/local/otrs/Kernel/cpan-lib /usr/local/otrs/ /usr/local/lib/perl5/site_perl/mach/5.26 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.26/mach /usr/local/lib/perl5/5.26) at /usr/local/otrs/Kernel/System/XML/Simple.pm line 14.\nBEGIN failed--compilation aborted at /usr/local/otrs/Kernel/System/XML/Simple.pm line 14.\nCompilation failed in require at /usr/local/otrs/Kernel/System/ObjectManager.pm line 254.\n at /usr/local/otrs/Kernel/System/ObjectManager.pm line 636.\n\tKernel::System::ObjectManager::_DieWithError(Kernel::System::ObjectManager=HASH(0x82a6b15b8), "Error", "Kernel::System::XML::Simple could not be loaded: Can't locate"...) called at /usr/local/otrs/Kernel/System/ObjectManager.pm line 261\n\tKernel::System::ObjectManager::_ObjectBuild(Kernel::System::ObjectManager=HASH(0x82a6b15b8), "Package", "Kernel::System::XML::Simple") called at /usr/local/otrs/Kernel/System/ObjectManager.pm line 200\n\tKernel::System::ObjectManager::Get(Kernel::System::ObjectManager=HASH(0x82a6b15b8), "Kernel::System::XML::Simple") called at /usr/local/otrs/Kernel/System/SysConfig/XML.pm line 129\n\tKernel::System::SysConfig::XML::SettingListParse(Kernel::System::SysConfig::XML=HASH(0x82f6c52b8), "XMLInput", "<?xml version=\\"1.0\\" encoding=\\"utf-8\\" ?>\\x{a}<otrs_config version="..., "XMLFilename", "Calendar.xml") called at /usr/local/otrs/Kernel/System/SysConfig.pm line 2543\n\tKernel::System::SysConfig::ConfigurationXML2DB(Kernel::System::SysConfig=HASH(0x82f2e3d20), "UserID", 1, "Directory", "/usr/local/otrs/Kernel/Config/Files/XML", "Force", 1, "CleanUp", ...) called at /usr/local/otrs/Kernel/Modules/Installer.pm line 1484\n\tKernel::Modules::Installer::_CheckConfig(Kernel::Modules::Installer=HASH(0x82e7c3570)) called at /usr/local/otrs/Kernel/Modules/Installer.pm line 719\n\tKernel::Modules::Installer::Run(Kernel::Modules::Installer=HASH(0x82e7c3570)) called at /usr/local/otrs/Kernel/System/Web/InterfaceInstaller.pm line 128\n\tKernel::System::Web::InterfaceInstaller::Run(Kernel::System::Web::InterfaceInstaller=HASH(0x82df038a0)) called at /usr/local/otrs/bin/cgi-bin/installer.pl line 39\n\tModPerl::ROOT::ModPerl::Registry::usr_local_otrs_bin_cgi_2dbin_installer_2epl::handler(Apache2::RequestRec=SCALAR(0x8288dea08)) called at /usr/local/lib/perl5/site_perl/mach/5.26/ModPerl/RegistryCooker.pm line 207\n\teval {...} called at /usr/local/lib/perl5/site_perl/mach/5.26/ModPerl/RegistryCooker.pm line 207\n\tModPerl::RegistryCooker::run(ModPerl::Registry=HASH(0x8289155d0)) called at /usr/local/lib/perl5/site_perl/mach/5.26/ModPerl/RegistryCooker.pm line 173\n\tModPerl::RegistryCooker::default_handler(ModPerl::Registry=HASH(0x8289155d0)) called at /usr/local/lib/perl5/site_perl/mach/5.26/ModPerl/Registry.pm line 32\n\tModPerl::Registry::handler("ModPerl::Registry", Apache2::RequestRec=SCALAR(0x8288dea08)) called at -e line 0\n\teval {...} called at -e line 0\n
Comment 1 m.tsatsenko 2018-10-26 21:32:40 UTC
Hello,
Thanks for using otrs port

The log suggests you are missing LibXML module and I am wondering why dont simply install it to make the software happy?
Comment 2 O. Hartmann 2018-10-30 12:53:40 UTC
I'm forced to build own packages for several reasons and I do not have access to the net on the target host. www/otrs is supposed to reel in all required ports when built via poudriere, right? I was wondering why this issue is still open, as it seems to be at least a part of Bug 229240.
Comment 3 O. Hartmann 2018-10-30 12:54:01 UTC

*** This bug has been marked as a duplicate of bug 229240 ***
Comment 4 m.tsatsenko 2018-11-03 22:38:51 UTC
Well. Yes and no
OTRS has dozens of dependencies, some of them mandatory like database support without them installed it simply doesnt work, others like XML and stuff are optional, i.e. they needed by specific functionality (in your case web installer) to work.
And since you are using binary packages the only option available for you is just install corresponding package to fit requirements.

As I can see you have closed PR and I am glad issue has been solved.