Bug 232763

Summary: net-mgmt/net-snmp: Build failed on 12-BETA2: keytools.c:156:9: error: invalid argument type 'void' to unary expression
Product: Ports & Packages Reporter: iron.udjin
Component: Individual Port(s)Assignee: Walter Schwarzenfeld <w.schwarzenfeld>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (zi)
Version: Latest   
Hardware: Any   
OS: Any   

Description iron.udjin 2018-10-28 14:56:53 UTC
Hello,

I'm trying to build net-snmp-5.7.3 on 12.0-BETA2 r339834:

/bin/sh ../libtool --mode=compile cc -I../include -I. 	-I../snmplib -I/usr/include -fno-strict-aliasing -O2 -pipe -march=native -march=native  -I/usr/local/include -I/include -fstack-protector -fno-strict-aliasing -std=c99  -Ufreebsd12 -Dfreebsd12=freebsd12  -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2  -I/usr/local/lib/perl5/5.24/mach/CORE -c -o keytools.lo keytools.c
libtool: compile:  cc -I../include -I. -I../snmplib -I/usr/include -fno-strict-aliasing -O2 -pipe -march=native -march=native -I/usr/local/include -I/include -fstack-protector -fno-strict-aliasing -std=c99 -Ufreebsd12 -Dfreebsd12=freebsd12 -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2 -I/usr/local/lib/perl5/5.24/mach/CORE -c keytools.c  -fPIC -DPIC -o .libs/keytools.o
keytools.c:156:9: error: invalid argument type 'void' to unary expression
    if (!EVP_MD_CTX_init(ctx))
        ^~~~~~~~~~~~~~~~~~~~~
1 error generated.
*** Error code 1
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-10-28 15:01:28 UTC
It is  a duplicate of bug #228898. There is a working patch (except TLS=on).
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-10-28 15:01:50 UTC

*** This bug has been marked as a duplicate of bug 228898 ***