Bug 233001

Summary: [patch] devel/hg-git: update to 0.8.12
Product: Ports & Packages Reporter: Anton Yuzhaninov <citrin+pr>
Component: Individual Port(s)Assignee: Steve Wills <swills>
Status: Closed FIXED    
Severity: Affects Only Me CC: marco.broeder
Priority: --- Flags: bugzilla: maintainer-feedback? (marco.broeder)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Update to 0.8.12 none

Description Anton Yuzhaninov 2018-11-05 19:59:23 UTC
Created attachment 198992 [details]
Update to 0.8.12

Please update port devel/hg-git to 0.8.12. This will allow to use hg-git with mercurial 4.7.2 (hg-git 0.8.10 is not compatible with mercurial 4.7.2).

Unfortunately mercurial 4.8 is not yet supported by hg-git: https://bitbucket.org/durin42/hg-git/issues/264/unexpected-keyword-argument-createopts-hg

Patch from files/ no longer needed and should be deleted.
Comment 1 commit-hook freebsd_committer 2018-11-23 16:01:58 UTC
A commit references this bug:

Author: swills
Date: Fri Nov 23 16:01:40 UTC 2018
New revision: 485687
URL: https://svnweb.freebsd.org/changeset/ports/485687

Log:
  devel/hg-git: update to 0.8.12

  PR:		233001
  Submitted by:	Anton Yuzhaninov <citrin+pr@citrin.ru>
  Approved by:	maintainer timeout (marco.broeder@posteo.eu, >2 weeks)

Changes:
  head/devel/hg-git/Makefile
  head/devel/hg-git/distinfo
  head/devel/hg-git/files/
Comment 2 Steve Wills freebsd_committer 2018-11-23 16:03:22 UTC
Committed, thanks!