Bug 233098

Summary: can not find lua loader
Product: Base System Reporter: rodriguezjulio86
Component: miscAssignee: freebsd-bugs (Nobody) <bugs>
Status: Open ---    
Severity: Affects Only Me CC: fbsdbugs4, johnjomurphy, kevans, rodrigo.freebsd, ruslan.yakauleu
Priority: --- Keywords: needs-qa
Version: CURRENT   
Hardware: amd64   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=234031
Attachments:
Description Flags
Screenshot failed boot none

Description rodriguezjulio86 2018-11-09 21:13:05 UTC
Version 12.0 Beta 3

"Startup error in /boot/lua/loader.lua:
LUA ERROR: Cannot open /boot/lua/loader.lua:
no such file or directory"
"can't load kernel"
Comment 1 Trev 2019-03-01 22:48:19 UTC
Created attachment 202490 [details]
Screenshot failed boot

12-STABLE i386 snapshot ISO of 20190207 installer fails to boot with same ewrror -- see attached screendump.

Hardware: macmini2,1
Comment 2 Trev 2019-12-09 01:31:50 UTC
See: https://forums.freebsd.org/threads/loader-lua-file-not-found-solved.73282/

Issue solved by fiddling with BIOS settings (not applicable to my Mac Mini though).
Comment 3 Ruslan Yakauleu 2020-03-25 16:11:49 UTC
Same issue with 12.1-RELEASE DVD on my notebook Toshiba Satellite L300
BIOS SATA Controller setting doesn't help.
Comment 4 John Murphy 2020-04-13 12:33:39 UTC
Same here. Tried every possible combination on a MBR machine and no success with 12.1
I'll have to move away from BSD soon because I can't risk some kind of failure and then the inability to create a new system to recover my files. 
This will be a great pity because the software is great and the community very helpful. But for me this is a showstopper.
The complete absence of a workaround is really, really surprising.