Bug 233269

Summary: devel/boost-libs: boost_mpi is missing
Product: Ports & Packages Reporter: Yuri Victorovich <yuri>
Component: Individual Port(s)Assignee: freebsd-office mailing list <office>
Status: New ---    
Severity: Affects Only Me CC: w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (office)
Version: Latest   
Hardware: Any   
OS: Any   

Description Yuri Victorovich freebsd_committer 2018-11-17 05:58:31 UTC
This CMakeLists.txt
> list(APPEND BOOST_COMPONENTS mpi serialization filesystem system)
> find_package(Boost "1.53.0" REQUIRED ${BOOST_COMPONENTS})
fails:
> CMake Error at /usr/local/share/cmake/Modules/FindBoost.cmake:2049 (message):
>   Unable to find the requested Boost libraries.
>   Boost version: 1.68.0
>   Boost include path: /usr/local/include
>   Could not find the following Boost libraries:
>           boost_mpi

I'm not sure if mpi should be in devel/boost-libs itself, or it should be a separate port.
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-02-12 06:23:26 UTC
We have Version 1.69.0_1. I think this issue is solved.
Comment 2 Yuri Victorovich freebsd_committer 2019-02-12 06:28:23 UTC
(In reply to w.schwarzenfeld from comment #1)

No, it's not solved.