Bug 233494

Summary: LLVM: BUG: Inconsistency in commandline options with multiple OpenCL vendor libraries installed
Product: Base System Reporter: O. Hartmann <ohartmann>
Component: binAssignee: freebsd-toolchain (Nobody) <toolchain>
Status: Closed DUPLICATE    
Severity: Affects Many People    
Priority: ---    
Version: CURRENT   
Hardware: Any   
OS: Any   

Description O. Hartmann 2018-11-25 09:31:13 UTC
I'd like to refer to this bug which seems to be still open and still present in all versions of LLVM since LLVM 4.0 (my guess, I did not track that down exactly).

Since this severe problem has not been solved even for LLVM 7.0, the issue not being able to use an ICD for multiple platforms available on FreeBSD in cases the OpenCL backends (lang/pocl (See https://github.com/pocl/pocl/issues/474), devel/beignet, lang/clover) are all compiled dynamically against the same LLVM backend. The issue disapperas were the backend is compiled against a different version of LLVM or statically linked. Both is inacceptable.

I'd like to refer to this LLVM bug:

http://lists.llvm.org/pipermail/llvm-bugs/2016-October/051237.html

and

Bug 30587 - Inconsistency in commandline options with multiple OpenCL vendor libraries installed :

https://bugs.llvm.org/show_bug.cgi?id=30587
Comment 1 O. Hartmann 2019-10-26 14:30:20 UTC

*** This bug has been marked as a duplicate of bug 233495 ***