Bug 233725

Summary: i386 build for many packages fails with undefined reference to `__atomic_load'
Product: Base System Reporter: Yuri Victorovich <yuri>
Component: miscAssignee: freebsd-toolchain mailing list <toolchain>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: dim
Priority: ---    
Version: CURRENT   
Hardware: Any   
OS: Any   

Description Yuri Victorovich freebsd_committer 2018-12-02 16:47:09 UTC
One example that came up recently is http://beefy10.nyi.freebsd.org/data/112i386-default/486388/logs/pcl-pointclouds-1.9.1.log, but there are other examples that have BROKEN_i386 for this reason.

Failure looks something like this:
> lib/libpcl_surface.so.1.9.1: undefined reference to `__atomic_load'
> clang-7: error: linker command failed with exit code 1 (use -v to see invocation)
Comment 1 Dimitry Andric freebsd_committer 2019-03-09 15:14:43 UTC

*** This bug has been marked as a duplicate of bug 230888 ***