Bug 233768

Summary: math/maxima: Stops working after lang/sbcl upgrade
Product: Ports & Packages Reporter: jszhao
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed FIXED    
Severity: Affects Only Me CC: krion, phascolarctos, pi
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232118
Attachments:
Description Flags
maxima - portrevision bump phascolarctos: maintainer-approval+

Description jszhao 2018-12-04 09:40:04 UTC
In FreeBSD, maxima was dependent on sbcl. However, when sbcl upgraded/updated, it seems that maxima also compiled again based on the new sbcl. However, maxima would not be updated by pkg. Thus, when invoking maxima after upgrading/updating sbcl, maxima always stop to work. Then, I have to delete maxima, reinstall it, and then it works.

Is it possible to reinstall maxima, when update/upgrading sbcl?
Comment 1 Lorenzo Salvadore 2018-12-04 10:13:43 UTC
I think in this case the solution is that Maxima's maintainer should bump PORTREVISION's value.

Maxima is not maintained at the moment. I asked to take maintainership and provided and update to version 5.42.1, but the bug report is still waiting for a committer: if you are interested, see #bug 232118.

No bumping of PORTREVISION is needed for my patch since PORTVERSION is already higher that ports tree's PORTVERSION.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-04 12:04:51 UTC
Kirill (krion) is lang/sblc's MAINTAINER, perhaps he can help here (CC'd).
Comment 3 Kurt Jaeger freebsd_committer 2019-01-27 11:52:57 UTC
After the latest maxima updates, does this problem still exist ?
Comment 4 Kurt Jaeger freebsd_committer 2019-01-27 13:18:18 UTC
I tested wxMaxima with the recent maxima, and it seems to work, so closing this ticket.
Comment 5 jszhao 2019-05-16 10:12:11 UTC
(In reply to Kurt Jaeger from comment #3)

After sbcl updated to sbcl-1.5.2,1, I run maxima, and I got the following message:

fatal error encountered in SBCL pid 6026(tid 0x800727000):
core was built for runtime "120amd64-default-job-21-root-2019-03-09-01-15-04" but this is "120amd64-default-job-21-root-2019-05-11-01-15-11"

I think it means that the maxima I used was not compiled using the that latest sbcl. Yes, it's the fact. The maxima not updated by pkg when it upgraded sbcl. So I have to remove maxima, and install maxima again, and then maxima works.

The original bug report, I might not describe the problem clearly.

Best,
Jinsong
Comment 6 Kurt Jaeger freebsd_committer 2019-05-16 10:28:59 UTC
Thanks for the heads-up and that the problem is solved!
Comment 7 Lorenzo Salvadore 2019-05-16 10:29:42 UTC
Created attachment 204397 [details]
maxima - portrevision bump

Apparently when sbcl is updated maxima needs a PORTREVISION bump.
Here is the patch for this time. I will follow sbcl updates and try to bump PORTREVISION as soon as possible, but if for some reason I am late and you need to report again, please open a new PR so we do not have to reopen the same PR multiple times.

Thank you.
Comment 8 Lorenzo Salvadore 2019-05-16 10:35:11 UTC
(In reply to Kurt Jaeger from comment #6)

I think jszhao is now reporting a new similar problem: look at the dates. The PR was opened 2018-12-04 09:40:04 UTC but in last post the oldest sbcl version was 120amd64-default-job-21-root-2019-03-09-01-15-04 .

A PORTREVISION bump is probably needed now.
Comment 9 Kirill Ponomarev freebsd_committer 2019-05-16 13:54:35 UTC
Thanks for investigating it, I will bump maxima portrevision while upgrading sbcl for new releases.