Bug 233799

Summary: ports-mgmt/pkg: pkg install should report if a port is broken instead of acting like it does not exist.
Product: Ports & Packages Reporter: Johannes Lundberg <johalun0>
Component: Individual Port(s)Assignee: freebsd-pkg mailing list <pkg>
Status: New ---    
Severity: Affects Only Me CC: bapt, grahamperrin
Priority: --- Flags: bugzilla: maintainer-feedback? (pkg)
Version: Latest   
Hardware: Any   
OS: Any   

Description Johannes Lundberg 2018-12-05 12:54:32 UTC
Just like the title says.

I tried to install a package "fs-uae" which I wasn't sure about the correct package name. `pkg install` or `pkg search` could not find any such package. I tried e-uae, uae, fs-uae-launcher but none gave me what I wanted. It turns out fs-uae was the correct name and that is has been marked broken. It would be nice if pkg could tell me about this. 

Cheers
Comment 1 Graham Perrin 2019-02-02 08:17:23 UTC
AFAICT from <https://www.freshports.org/emulators/fs-uae/> it's no longer marked as BROKEN. 

For me, 

root@momh167-gjp4-8570p:~ # pkg rquery %e -r FreeBSD fs-uae
root@momh167-gjp4-8570p:~ # date ; uname -v
Sat Feb  2 08:16:30 GMT 2019
FreeBSD 13.0-CURRENT r343308 GENERIC-NODEBUG 
root@momh167-gjp4-8570p:~ # 

– I guess that it's not in the repo for 13.0-CURRENT.
Comment 2 Graham Perrin 2019-02-02 08:34:45 UTC
> – I guess that it's not in the repo for 13.0-CURRENT.

fs-uae-launcher-2.8.4_2.txz is listed at 
<https://pkg.freebsd.org/FreeBSD:12:amd64/latest/All/>

No comparable file at 
<https://pkg.freebsd.org/FreeBSD:13:amd64/latest/All/>