Bug 233803

Summary: mail/p5-Email-Sender: Depends on deprecated mail/p5-Email-Address
Product: Ports & Packages Reporter: William F. Dudley Jr. <wfdudley>
Component: Individual Port(s)Assignee: Kurt Jaeger <pi>
Status: Closed FIXED    
Severity: Affects Some People CC: bill.brinzer, dougs, jkeenan, pi
Priority: --- Flags: pi: maintainer-feedback-
pi: merge-quarterly+
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch none

Description William F. Dudley Jr. 2018-12-05 15:44:22 UTC
The package p5-Email-Sender depends on p5-Email-Address, which is deprecated.
I understand that p5-Email-Address-XS can be used as a replacement for
p5-Email-Address.

p5-Email-Address-1.909: Tag: expiration_date Value: 2018-12-31
p5-Email-Address-1.909: Tag: deprecated Value: Deprecated by upstream
Comment 1 Kurt Jaeger freebsd_committer 2019-01-03 19:00:26 UTC
Created attachment 200745 [details]
patch

Change from RUN_DEPEND on mail/p5-Email-Address to mail/p5-Email-Address-XS
as suggested. Testbuilds are fine.
Comment 2 commit-hook freebsd_committer 2019-01-03 19:09:20 UTC
A commit references this bug:

Author: pi
Date: Thu Jan  3 19:08:49 UTC 2019
New revision: 489202
URL: https://svnweb.freebsd.org/changeset/ports/489202

Log:
  mail/p5-Email-Sender: change RUN_DEPENDS

  - port depends on p5-Email-Address, which is deprecated
  - p5-Email-Address-XS can be used as a replacement

  PR:		233803
  Submitted by:	wfdudley@gmail.com
  Approved by:	bill.brinzer@gmail.com (maintainer timeout)
  MFH:		2019Q1

Changes:
  head/mail/p5-Email-Sender/Makefile
Comment 3 commit-hook freebsd_committer 2019-01-04 04:11:45 UTC
A commit references this bug:

Author: pi
Date: Fri Jan  4 04:11:16 UTC 2019
New revision: 489242
URL: https://svnweb.freebsd.org/changeset/ports/489242

Log:
  MFH: r489202

  mail/p5-Email-Sender: change RUN_DEPENDS

  - port depends on p5-Email-Address, which is deprecated
  - p5-Email-Address-XS can be used as a replacement

  PR:		233803
  Submitted by:	wfdudley@gmail.com
  Approved by:	bill.brinzer@gmail.com (maintainer timeout)
  Approved by:	portmgr (miwi)

Changes:
_U  branches/2019Q1/
  branches/2019Q1/mail/p5-Email-Sender/Makefile
Comment 4 Kurt Jaeger freebsd_committer 2019-01-04 04:13:20 UTC
Committed, thanks!
Comment 5 Dan Langille freebsd_committer 2019-01-04 18:17:20 UTC
*** Bug 228327 has been marked as a duplicate of this bug. ***
Comment 6 commit-hook freebsd_committer 2019-01-04 19:28:16 UTC
A commit references this bug:

Author: pi
Date: Fri Jan  4 19:27:37 UTC 2019
New revision: 489265
URL: https://svnweb.freebsd.org/changeset/ports/489265

Log:
  p5-Email-Sender: change run-dep Email-Address-XS back to Email-Address

  - the run-dep Email-Address-XS is not used by the module without
    Email-Address-UseXS
  - So it's either add Email-Address-UseXS or back to Email-Address

  PR:		233803
  Reported by:	dvl
  Approved by:	unbreak blanket

Changes:
  head/mail/p5-Email-Sender/Makefile
Comment 7 commit-hook freebsd_committer 2019-02-07 21:16:33 UTC
A commit references this bug:

Author: pi
Date: Thu Feb  7 21:15:54 UTC 2019
New revision: 492385
URL: https://svnweb.freebsd.org/changeset/ports/492385

Log:
  MFH: r489261 r489265

  mail/p5-Email-Address: update 1.909 -> 1.912, undeprecate by upstream

  Reported by:	Benjamin Connelly <ben@electricembers.coop>
  Relnotes:	https://metacpan.org/changes/distribution/Email-Address

  p5-Email-Sender: change run-dep Email-Address-XS back to Email-Address

  - the run-dep Email-Address-XS is not used by the module without
    Email-Address-UseXS
  - So it's either add Email-Address-UseXS or back to Email-Address

  PR:		233803
  Reported by:	dvl, Dan Mahoney <dmahoney@isc.org>
  Approved by:	portmgr (unbreak blanket and CVE for RT)

Changes:
_U  branches/2019Q1/
  branches/2019Q1/mail/p5-Email-Address/Makefile
  branches/2019Q1/mail/p5-Email-Address/distinfo
  branches/2019Q1/mail/p5-Email-Sender/Makefile