Bug 233964

Summary: www/ufdbguard: Fails to build with OpenSSL 1.1.1 on FreeBSD 12 (error: incomplete definition of type 'struct ssl_st')
Product: Ports & Packages Reporter: ncrogers
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed DUPLICATE    
Severity: Affects Some People CC: timp87, w.schwarzenfeld
Priority: --- Keywords: needs-qa
Version: LatestFlags: bugzilla: maintainer-feedback? (timp87)
koobs: merge-quarterly?
Hardware: amd64   
OS: Any   
Bug Depends on:    
Bug Blocks: 231931    
Attachments:
Description Flags
poudriere log
none
port patch
timp87: maintainer-approval+
patch-src-ufbdchkport.c
none
port patch with fix timp87: maintainer-approval+

Description ncrogers 2018-12-12 18:24:08 UTC
Created attachment 200062 [details]
poudriere log

ufdbguard fails to build under 12.0-RELEASE. poudriere log is attached.
Comment 1 timp87 2018-12-12 18:53:35 UTC
This is related to openssl-1.1 in FreeBSD 12. Sorry for this, ufdbguard-1.34 supports new openssl, but it is rc7 now. According to developer the only thing left to release it is the man page
Comment 2 timp87 2018-12-18 18:57:26 UTC
Created attachment 200237 [details]
port patch

Mark it BROKEN on FreeBSD 12 for now
Comment 3 timp87 2018-12-19 15:33:16 UTC
Could anybody commit it please? Those emails about package build failure are a bit annoying
Comment 4 ncrogers 2018-12-19 16:13:00 UTC
Does your patch suggest that we should be using openssl from ports?
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-12-19 17:01:01 UTC
Created attachment 200274 [details]
patch-src-ufbdchkport.c

This is working with libressl (I think it should also work with openssl - not tested with it).
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-12-19 19:52:42 UTC
(In reply to w.schwarzenfeld from comment #5)
The patch works with openssl-base and libressl , but not openssl111.
Comment 7 timp87 2019-01-09 08:02:23 UTC
Let me check and update the port patch
Comment 8 timp87 2019-01-09 08:54:16 UTC
Created attachment 200949 [details]
port patch with fix

- Mark it broken on FreeBSD 12 with its base openssl 1.1
- Add a patch to make it build with libressl (thanks to w.schwarzenfeld!)
Comment 9 Walter Schwarzenfeld freebsd_triage 2019-01-09 10:03:27 UTC
Version 1.33.8 is released:
https://www.urlfilterdb.com/products/releases.html

but I doubt it changes something with ssl:
Comment 10 timp87 2019-01-09 10:11:14 UTC
(In reply to w.schwarzenfeld from comment #9)
It doesn't. 1.34 will
Comment 11 timp87 2019-01-10 06:35:00 UTC
merge-quarterly is needed BTW
Comment 12 ncrogers 2019-02-05 21:18:15 UTC
1.34.1  was finally released today!
Comment 13 timp87 2019-02-08 07:51:29 UTC
This PR may be superseded by 
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235591
Comment 14 ncrogers 2019-02-08 19:12:28 UTC

*** This bug has been marked as a duplicate of bug 235591 ***